aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-06-07 02:11:51 +0800
committerMatthias Andree <mandree@FreeBSD.org>2014-06-07 02:11:51 +0800
commit2ddc98040c1c957464dbdc53c523e62eff4add15 (patch)
tree6aa74094c54109be7a9a81b35fd5dd8f6616deaa /dns
parent0f17a28467c297038f5afee1a6e64ca32c396f6f (diff)
downloadfreebsd-ports-gnome-2ddc98040c1c957464dbdc53c523e62eff4add15.tar.gz
freebsd-ports-gnome-2ddc98040c1c957464dbdc53c523e62eff4add15.tar.zst
freebsd-ports-gnome-2ddc98040c1c957464dbdc53c523e62eff4add15.zip
Fix build with LUA option enabled [1]; modernize USE_BZIP2.
[1] Recent changes to the Lua ports cause a build failure and have broken powerdns-recursor when LUA is enabled. USES+= lua:51 also no longer worked so had to pet the Makefile a little. [mandree] modernize USE_BZIP2 -> USES=tar:bzip2 PR: 190698 Submitted by: tremere@cainites.net Approved by: portmgr (blanket)
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-recursor/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 0276378d0daa..d5e9363866f1 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -14,8 +14,7 @@ COMMENT= Advanced DNS recursor
BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
OPTIONS_DEFINE= SETUID LUA STATIC
OPTIONS_DEFAULT= SETUID
@@ -27,7 +26,7 @@ LDFLAGS+= -L${PREFIX}/lib
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
@@ -42,11 +41,10 @@ GROUPS= pdns
.endif
.if ${PORT_OPTIONS:MLUA}
-USES+= lua:51
-LUA_COMPS=lua
+USES+= lua:51
MAKE_ENV+=LUA=1
-MAKE_ENV+=LUA_CPPFLAGS_CONFIG=-I${PREFIX}/include/lua51
-MAKE_ENV+="LUA_LIBS_CONFIG=-L${PREFIX}/lib/lua51/ -llua-${LUA_VER}"
+MAKE_ENV+="LUA_CPPFLAGS_CONFIG=-I${LUA_INCDIR}"
+MAKE_ENV+="LUA_LIBS_CONFIG=-L${LUA_LIBDIR} -llua-${LUA_VER}"
.endif
.if ${PORT_OPTIONS:MSTATIC}
@@ -72,4 +70,4 @@ post-patch:
post-install:
${INSTALL_MAN} ${WRKSRC}/*.8 ${STAGEDIR}${PREFIX}/man/man8/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>