aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorjhixson <jhixson@FreeBSD.org>2019-01-08 16:51:57 +0800
committerjhixson <jhixson@FreeBSD.org>2019-01-08 16:51:57 +0800
commit329feb10cb099bf1701ee70730e6776f18e93d29 (patch)
tree63e6c6867b04350d471825f5f06df2bb9fa00e33 /dns
parente29f7978982c52afb8d3a99bcbd41035a72e9947 (diff)
downloadfreebsd-ports-gnome-329feb10cb099bf1701ee70730e6776f18e93d29.tar.gz
freebsd-ports-gnome-329feb10cb099bf1701ee70730e6776f18e93d29.tar.zst
freebsd-ports-gnome-329feb10cb099bf1701ee70730e6776f18e93d29.zip
[new port] dns/py-bonjour: Python interface for mDNSResponder
PR: 225851 Approved by: araujo (mentor) Differential Revision: https://reviews.freebsd.org/D18782
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-bonjour/Makefile24
-rw-r--r--dns/py-bonjour/distinfo3
-rw-r--r--dns/py-bonjour/files/patch-pybonjour.py11
-rw-r--r--dns/py-bonjour/pkg-descr7
5 files changed, 46 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index b56434381faf..a41e93f0ccfa 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -183,6 +183,7 @@
SUBDIR += public_suffix_list
SUBDIR += py-adns
SUBDIR += py-aiodns
+ SUBDIR += py-bonjour
SUBDIR += py-cloudflare
SUBDIR += py-dns
SUBDIR += py-dns-lexicon
diff --git a/dns/py-bonjour/Makefile b/dns/py-bonjour/Makefile
new file mode 100644
index 000000000000..6c7aa3767cfc
--- /dev/null
+++ b/dns/py-bonjour/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= pybonjour
+PORTVERSION= 1.1.1
+CATEGORIES= dns python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jhixson@freebsd.org
+COMMENT= Pure-Python interface to Apple Bonjour
+
+LICENSE= MIT
+
+LIB_DEPENDS= libdns_sd.so.1:net/mDNSResponder
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+USE_GITHUB= yes
+GH_ACCOUNT= depl0y
+GH_PROJECT= pybonjour-python3
+GH_TAGNAME= 2c8283f
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/dns/py-bonjour/distinfo b/dns/py-bonjour/distinfo
new file mode 100644
index 000000000000..362d116f4519
--- /dev/null
+++ b/dns/py-bonjour/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518466005
+SHA256 (depl0y-pybonjour-python3-1.1.1-2c8283f_GH0.tar.gz) = ec180cf9c9c2e36fe827c294d0c45903846c15af76e19833be867cbe8df3e333
+SIZE (depl0y-pybonjour-python3-1.1.1-2c8283f_GH0.tar.gz) = 18776
diff --git a/dns/py-bonjour/files/patch-pybonjour.py b/dns/py-bonjour/files/patch-pybonjour.py
new file mode 100644
index 000000000000..3fc2ac9ad96f
--- /dev/null
+++ b/dns/py-bonjour/files/patch-pybonjour.py
@@ -0,0 +1,11 @@
+--- pybonjour.py.orig 2013-10-02 17:41:05 UTC
++++ pybonjour.py
+@@ -1116,7 +1116,7 @@ def DNSServiceRegister(
+ type=type(txtRecord)))
+
+ if not txtRecord:
+- txtLen, txtRecord = 1, '\0'
++ txtLen, txtRecord = 1, '\0'.encode('utf-8')
+ else:
+ txtLen, txtRecord = _string_to_length_and_void_p(txtRecord)
+
diff --git a/dns/py-bonjour/pkg-descr b/dns/py-bonjour/pkg-descr
new file mode 100644
index 000000000000..2a4673e5e002
--- /dev/null
+++ b/dns/py-bonjour/pkg-descr
@@ -0,0 +1,7 @@
+pybonjour provides a pure-Python interface (via ctypes) to Apple
+Bonjour and compatible DNS-SD libraries (such as Avahi). It allows
+Python scripts to take advantage of Zero Configuration Networking
+(Zeroconf) to register, discover, and resolve services on both local
+and wide-area networks.
+
+WWW: https://github.com/depl0y/pybonjour-python3