aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2008-05-07 19:33:37 +0800
committersem <sem@FreeBSD.org>2008-05-07 19:33:37 +0800
commit408944ab38026813775581c8b07309471b8b5d10 (patch)
tree4a29f2a0a91bde56582b1d3bfad242ccbf501429 /dns
parent090c8c5592ac787328ef8fd3811faee9437a5bfa (diff)
downloadfreebsd-ports-gnome-408944ab38026813775581c8b07309471b8b5d10.tar.gz
freebsd-ports-gnome-408944ab38026813775581c8b07309471b8b5d10.tar.zst
freebsd-ports-gnome-408944ab38026813775581c8b07309471b8b5d10.zip
- unbound runned in chroot by default. it brings us a problem with
pid file. place it to PREFIX/etc/unbound as an author do.
Diffstat (limited to 'dns')
-rw-r--r--dns/unbound/Makefile5
-rw-r--r--dns/unbound/files/patch-configure11
-rw-r--r--dns/unbound/files/pkg-install.in5
-rw-r--r--dns/unbound/files/unbound.in2
4 files changed, 8 insertions, 15 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index f8ef606b0188..dc3c8bc732e0 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unbound
PORTVERSION= 0.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
@@ -44,4 +44,7 @@ post-patch:
pre-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.post.mk>
diff --git a/dns/unbound/files/patch-configure b/dns/unbound/files/patch-configure
deleted file mode 100644
index 14b77d38081d..000000000000
--- a/dns/unbound/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2008-04-25 18:25:51.000000000 +0400
-+++ configure 2008-04-25 18:26:00.000000000 +0400
-@@ -3300,7 +3300,7 @@
-
-
- cat >>confdefs.h <<_ACEOF
--#define PIDFILE "$ub_dir/unbound.pid"
-+#define PIDFILE "/var/run/unbound.pid"
- _ACEOF
-
-
diff --git a/dns/unbound/files/pkg-install.in b/dns/unbound/files/pkg-install.in
index 3acf7b173dee..d0a4e30bec4f 100644
--- a/dns/unbound/files/pkg-install.in
+++ b/dns/unbound/files/pkg-install.in
@@ -37,9 +37,10 @@ PRE-INSTALL)
exit 1
fi
fi
+ ;;
- [ -d /var/run/unbound ] || mkdir -p /var/run/unbound
- chown "${USER}" /var/run/unbound
+POST-INSTALL)
+ chown "${USER}" $PREFIX/etc/unbound
;;
*)
;;
diff --git a/dns/unbound/files/unbound.in b/dns/unbound/files/unbound.in
index 39645656c501..7ce99cee38b8 100644
--- a/dns/unbound/files/unbound.in
+++ b/dns/unbound/files/unbound.in
@@ -16,7 +16,7 @@ name="unbound"
rcvar=`set_rcvar`
command="%%PREFIX%%/sbin/unbound"
-pidfile="/var/run/unbound/unbound.pid"
+pidfile="%%PREFIX%%/etc/unbound/unbound.pid"
extra_commands="reload"
load_rc_config $name