aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-15 18:12:08 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-15 18:12:08 +0800
commit581cac9416d38f70a9e5c680d9751230bd43cbc4 (patch)
tree4ec74f3dd744ca8054cce78df35237dd5b189528 /dns
parent2f26d37a5937d9b654ab7ef7fc9f16733f276fce (diff)
downloadfreebsd-ports-gnome-581cac9416d38f70a9e5c680d9751230bd43cbc4.tar.gz
freebsd-ports-gnome-581cac9416d38f70a9e5c680d9751230bd43cbc4.tar.zst
freebsd-ports-gnome-581cac9416d38f70a9e5c680d9751230bd43cbc4.zip
Move remaining USE_MYSQL, WANT_MYSQL_VER to USES=mysql
Diffstat (limited to 'dns')
-rw-r--r--dns/mydns-ng/Makefile2
-rw-r--r--dns/mydns/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index e37d8065d2cf..2fc641a492b5 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -42,7 +42,7 @@ PGSQL_CONFIGURE_ON= --with-pgsql \
--with-pgsql-lib=${LOCALBASE}/lib
PGSQL_CONFIGURE_OFF= --without-pgsql
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql \
--with-mysql-include=${LOCALBASE}/include/mysql \
--with-mysql-lib=${LOCALBASE}/lib/mysql
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index a6846cbcd5d8..d15c53938546 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -46,11 +46,11 @@ CONFIGURE_ARGS+=--without-mysql \
--with-pgsql-lib=${LOCALBASE}/lib
PKGNAMESUFFIX= -pg
.else
+USES+= mysql
CONFIGURE_ARGS+=--without-pgsql \
--with-mysql-include=${LOCALBASE}/include/mysql \
--with-mysql-lib=${LOCALBASE}/lib/mysql
PKGNAMESUFFIX= -mysql
-USE_MYSQL= yes
.endif
.if ${PORT_OPTIONS:MNLS}