aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-23 05:47:38 +0800
committerantoine <antoine@FreeBSD.org>2014-12-23 05:47:38 +0800
commit5dbde647ae68d48c3be8163083238b2f5cd2d15e (patch)
tree84c2f43f818acda540dd8ddd74030762b6a86d16 /dns
parentad7884acfcb990fbf8ced7bfae915595990c1412 (diff)
downloadfreebsd-ports-gnome-5dbde647ae68d48c3be8163083238b2f5cd2d15e.tar.gz
freebsd-ports-gnome-5dbde647ae68d48c3be8163083238b2f5cd2d15e.tar.zst
freebsd-ports-gnome-5dbde647ae68d48c3be8163083238b2f5cd2d15e.zip
Shebangfix
Diffstat (limited to 'dns')
-rw-r--r--dns/rbllookup/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/dns/rbllookup/Makefile b/dns/rbllookup/Makefile
index b0a621673e5b..19bb5799583d 100644
--- a/dns/rbllookup/Makefile
+++ b/dns/rbllookup/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rbllookup
PORTVERSION= 0.0.1.1
+PORTREVISION= 1
CATEGORIES= dns mail
MASTER_SITES= SF
@@ -12,8 +13,10 @@ COMMENT= Check given IP/Host presence in 106 RBLs
BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
p5-Term-ANSIColor>=0:${PORTSDIR}/devel/p5-Term-ANSIColor
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= rbl.pl
NO_BUILD= yes
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/rbllookup
PORTDOCS= CHANGELOG INSTALL NOTES README TODO gpg.asc
@@ -21,8 +24,8 @@ PORTDOCS= CHANGELOG INSTALL NOTES README TODO gpg.asc
OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/rbl.pl ${STAGEDIR}${PREFIX}/bin/rbllookup
+ ${INSTALL_SCRIPT} ${WRKSRC}/rbl.pl ${STAGEDIR}${PREFIX}/bin/rbllookup
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKDIR} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>