aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-24 10:30:22 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-24 10:30:22 +0800
commit6cc8f6c2796fb1225400f5aa183c07ed88991411 (patch)
treee9b1427e300955f05f526ac69b7a48abdb08940f /dns
parent856d7b970a90ec66fb75ff35493d93e9c2a28e8e (diff)
downloadfreebsd-ports-gnome-6cc8f6c2796fb1225400f5aa183c07ed88991411.tar.gz
freebsd-ports-gnome-6cc8f6c2796fb1225400f5aa183c07ed88991411.tar.zst
freebsd-ports-gnome-6cc8f6c2796fb1225400f5aa183c07ed88991411.zip
dns/powerdns-recursor: work around crash with boost 1.62
Assertion failed: (this != &x), function operator=, file /usr/local/include/boost/container/string.hpp, line 830. PR: 214470 Approved by: Ralf van der Enden <tremere@cainites.net> (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-recursor/Makefile2
-rw-r--r--dns/powerdns-recursor/files/patch-dnsname.hh22
2 files changed, 23 insertions, 1 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 2861b479502c..103d71fc8368 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= recursor
PORTVERSION= 4.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
PKGNAMEPREFIX= powerdns-
diff --git a/dns/powerdns-recursor/files/patch-dnsname.hh b/dns/powerdns-recursor/files/patch-dnsname.hh
new file mode 100644
index 000000000000..3f110e832d3e
--- /dev/null
+++ b/dns/powerdns-recursor/files/patch-dnsname.hh
@@ -0,0 +1,22 @@
+https://github.com/PowerDNS/pdns/issues/2955
+
+--- dnsname.hh.orig 2016-09-06 12:50:29 UTC
++++ dnsname.hh
+@@ -30,7 +30,7 @@
+ #include <boost/version.hpp>
+
+ // it crashes on OSX and doesn't compile on OpenBSD
+-#if BOOST_VERSION >= 104800 && ! defined( __APPLE__ ) && ! defined(__OpenBSD__)
++#if BOOST_VERSION >= 104800 && ! defined(_LIBCPP_VERSION) && ! defined(__OpenBSD__)
+ #include <boost/container/string.hpp>
+ #endif
+
+@@ -133,7 +133,7 @@ public:
+ inline bool canonCompare(const DNSName& rhs) const;
+ bool slowCanonCompare(const DNSName& rhs) const;
+
+-#if BOOST_VERSION >= 104800 && ! defined( __APPLE__ ) && ! defined(__OpenBSD__)
++#if BOOST_VERSION >= 104800 && ! defined(_LIBCPP_VERSION) && ! defined(__OpenBSD__)
+ typedef boost::container::string string_t;
+ #else
+ typedef std::string string_t;