aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
commit6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7 (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /dns
parentb236a9c0408bb4c5dd28e3128687a5de61161a27 (diff)
downloadfreebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.gz
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.zst
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Diffstat (limited to 'dns')
-rw-r--r--dns/hesiod/Makefile1
-rw-r--r--dns/knot1/Makefile4
-rw-r--r--dns/knot2/Makefile4
3 files changed, 0 insertions, 9 deletions
diff --git a/dns/hesiod/Makefile b/dns/hesiod/Makefile
index 9d4674774786..b22c3fed5892 100644
--- a/dns/hesiod/Makefile
+++ b/dns/hesiod/Makefile
@@ -18,7 +18,6 @@ OPTIONS_DEFAULT=IDN
USES= libtool pathfix
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/dns/knot1/Makefile b/dns/knot1/Makefile
index 7c3754016145..e58e10430625 100644
--- a/dns/knot1/Makefile
+++ b/dns/knot1/Makefile
@@ -27,10 +27,6 @@ USE_LDCONFIG= yes
USE_OPENSSL= yes
WITH_OPENSSL_PORT= yes
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-CONFIGURE_ARGS+= --disable-silent-rules
-.endif
-
INSTALL_TARGET= install-strip
USE_RC_SUBR= ${PORTNAME}
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index 72b5787c6673..39a4d2f6249d 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -30,10 +30,6 @@ CONFIGURE_ARGS= --with-rundir=/var/run/knot \
--with-storage=/var/db/knot \
--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-CONFIGURE_ARGS+= --disable-silent-rules
-.endif
-
INSTALL_TARGET= install-strip
USE_RC_SUBR= ${PORTNAME}