aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-11-04 22:06:47 +0800
committerMathieu Arnold <mat@FreeBSD.org>2019-11-04 22:06:47 +0800
commit6ea10085b9db3f614eb3384e5a978c05571b5b4e (patch)
tree24674dcc1a9031e9419f7ed0f24ee26ddcac3345 /dns
parent003a8cf25169287d390ce3f7b9b522ac28fed3b2 (diff)
downloadfreebsd-ports-gnome-6ea10085b9db3f614eb3384e5a978c05571b5b4e.tar.gz
freebsd-ports-gnome-6ea10085b9db3f614eb3384e5a978c05571b5b4e.tar.zst
freebsd-ports-gnome-6ea10085b9db3f614eb3384e5a978c05571b5b4e.zip
Update to latest commit.
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
3 files changed, 11 insertions, 11 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 360094b45edd..ca8adc0cdf1e 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -41,13 +41,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.5a0.2019.10.29
+ISCVERSION= 9.15.5a0.2019.10.31
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 82f07b2c6d52184f83ee7e8b3772b5439ad73bd9
+GL_COMMIT= d2fdebe02ef58e3b2affe429c028741c4405022b
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index e4279c769929..8bb7f873fa7c 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1572345707
-SHA256 (isc-projects-bind9-82f07b2c6d52184f83ee7e8b3772b5439ad73bd9_GL0.tar.gz) = 941ba603c2d8d7d592d666bb955c84934f34fdc6522d1fabfb3f508b42bfc146
-SIZE (isc-projects-bind9-82f07b2c6d52184f83ee7e8b3772b5439ad73bd9_GL0.tar.gz) = 6340274
+TIMESTAMP = 1572875413
+SHA256 (isc-projects-bind9-d2fdebe02ef58e3b2affe429c028741c4405022b_GL0.tar.gz) = 13322a79b0c291b0641e78330b18ea3563df5dfb0aac74b54bdf992aaf7dbac1
+SIZE (isc-projects-bind9-d2fdebe02ef58e3b2affe429c028741c4405022b_GL0.tar.gz) = 6339384
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index b41c3d66e6a5..20a93538bde6 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2019-10-06 03:16:14 UTC
+--- bin/named/config.c.orig 2019-10-31 19:19:57 UTC
+++ bin/named/config.c
@@ -177,6 +177,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-10-06 03:16:14 UTC
+--- bin/named/server.c.orig 2019-10-31 19:19:57 UTC
+++ bin/named/server.c
@@ -4215,6 +4215,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-10-06 03:16:14 UTC
+--- lib/dns/include/dns/view.h.orig 2019-10-31 19:19:57 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-10-06 03:16:14 UTC
+--- lib/dns/resolver.c.orig 2019-10-31 19:19:57 UTC
+++ lib/dns/resolver.c
-@@ -6028,6 +6028,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6056,6 +6056,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-10-06 03:16:14 UTC
+--- lib/isccfg/namedconf.c.orig 2019-10-31 19:19:57 UTC
+++ lib/isccfg/namedconf.c
@@ -1907,6 +1907,7 @@ view_clauses[] = {
#endif