aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-11-02 18:13:14 +0800
committermat <mat@FreeBSD.org>2018-11-02 18:13:14 +0800
commit6f54054a1307f3570fae672c42c425146f154115 (patch)
treec1fe3cd5629563dadcf7c730a94316675777db89 /dns
parent82ffa878a43f812d40ad6f4d02d5c30966997441 (diff)
downloadfreebsd-ports-gnome-6f54054a1307f3570fae672c42c425146f154115.tar.gz
freebsd-ports-gnome-6f54054a1307f3570fae672c42c425146f154115.tar.zst
freebsd-ports-gnome-6f54054a1307f3570fae672c42c425146f154115.zip
Remove GOST support from BIND9 9.11 and 9.12.
It was never (widely|really) used, and support for it has been dropped in OpenSSL starting at 1.1, and BIND9 starting at 9.13. PR: 231980 Reported by: mfechner
Diffstat (limited to 'dns')
-rw-r--r--dns/bind911/Makefile20
-rw-r--r--dns/bind912/Makefile20
2 files changed, 2 insertions, 38 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index b7108e1523d1..3300832e6b9f 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -56,9 +56,8 @@ OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
MINCACHE PORTREVISION QUERYTRACE LMDB DNSTAP \
START_LATE TUNING_LARGE TCP_FASTOPEN
-OPTIONS_RADIO= CRYPTO GOSTDEF
+OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
-OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
@@ -80,9 +79,6 @@ DNSTAP_DESC= Provides fast passive logging of DNS messages
FILTER_AAAA_DESC= Enable filtering of AAAA records
FIXED_RRSET_DESC= Enable fixed rrset ordering
GEOIP_DESC= Allow geographically based ACL.
-GOSTDEF_DESC= Enable GOST ciphers, needs SSL
-GOST_ASN1_DESC= GOST using ASN.1
-GOST_DESC= GOST raw keys (new default)
GSSAPI_BASE_DESC= Using Heimdal in base
GSSAPI_HEIMDAL_DESC= Using security/heimdal
GSSAPI_MIT_DESC= Using security/krb5
@@ -131,10 +127,6 @@ FIXED_RRSET_CONFIGURE_ENABLE= fixed-rrset
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
-GOST_ASN1_CONFIGURE_ON= --with-gost=asn1
-
-GOST_CONFIGURE_ON= --with-gost
-
GSSAPI_BASE_CONFIGURE_ON=\
--with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_BASE_USES= gssapi
@@ -199,16 +191,6 @@ TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
.include <bsd.port.pre.mk>
-.if !${PORT_OPTIONS:MGOST} && !${PORT_OPTIONS:MGOST_ASN1}
-CONFIGURE_ARGS+= --without-gost
-.endif
-
-.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && ${SSL_DEFAULT} == base
-BROKEN= OpenSSL from the base system does not support GOST, add \
- DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
- that needs SSL.
-.endif
-
post-patch:
.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.1 \
rndc/rndc.8
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index b165e88ccbb4..2b344a8de3b9 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -72,9 +72,8 @@ OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS
-OPTIONS_RADIO= CRYPTO GOSTDEF
+OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
-OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
OPTIONS_DEFAULT+= DLZ_FILESYSTEM LMDB RPZ_NSDNAME RPZ_NSIP TCP_FASTOPEN
@@ -101,9 +100,6 @@ DLZ_STUB_DESC= DLZ stub driver
DNSTAP_DESC= Provides fast passive logging of DNS messages
FIXED_RRSET_DESC= Enable fixed rrset ordering
GEOIP_DESC= Allow geographically based ACL.
-GOSTDEF_DESC= Enable GOST ciphers, needs SSL
-GOST_ASN1_DESC= GOST using ASN.1
-GOST_DESC= GOST raw keys (new default)
GSSAPI_BASE_DESC= Using Heimdal in base
GSSAPI_HEIMDAL_DESC= Using security/heimdal
GSSAPI_MIT_DESC= Using security/krb5
@@ -150,10 +146,6 @@ FIXED_RRSET_CONFIGURE_ENABLE= fixed-rrset
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
-GOST_ASN1_CONFIGURE_ON= --with-gost=asn1
-
-GOST_CONFIGURE_ON= --with-gost
-
GSSAPI_BASE_CONFIGURE_ON=\
--with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_BASE_USES= gssapi
@@ -220,16 +212,6 @@ TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
.include <bsd.port.pre.mk>
-.if !${PORT_OPTIONS:MGOST} && !${PORT_OPTIONS:MGOST_ASN1}
-CONFIGURE_ARGS+= --without-gost
-.endif
-
-.if ( ${PORT_OPTIONS:MGOST} || ${PORT_OPTIONS:MGOST_ASN1} ) && ${SSL_DEFAULT} == base
-BROKEN= OpenSSL from the base system does not support GOST, add \
- DEFAULT_VERSIONS+=ssl=openssl to your /etc/make.conf and rebuild everything \
- that needs SSL.
-.endif
-
post-patch:
.if defined(BIND_TOOLS_SLAVE)
@${REINPLACE_CMD} -e 's#^SUBDIRS.*#SUBDIRS = lib bin#' \