aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committerMathieu Arnold <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /dns
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadfreebsd-ports-gnome-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
freebsd-ports-gnome-7c47779cb9cc1f12908949c26b831e944047ed17.tar.zst
freebsd-ports-gnome-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/ddclient/Makefile4
-rw-r--r--dns/ddclient/files/patch-ddclient7
2 files changed, 1 insertions, 10 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index 1acedc4ec93a..045da491dfa4 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -36,9 +36,7 @@ PLIST_FILES= etc/ddclient.conf.sample etc/periodic/daily/ddclient_force \
post-patch:
@${GREP} -lR '/usr' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|/usr|${PREFIX}|g'
- @${REINPLACE_CMD} -e \
- 's|%%PERL%%|${PERL}| ; \
- s|%%ETCDIR%%|${PREFIX}/etc| ; \
+ @${REINPLACE_CMD} -e 's|%%ETCDIR%%|${PREFIX}/etc| ; \
s|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/ddclient
do-install:
diff --git a/dns/ddclient/files/patch-ddclient b/dns/ddclient/files/patch-ddclient
index a1b387838737..0891470636ac 100644
--- a/dns/ddclient/files/patch-ddclient
+++ b/dns/ddclient/files/patch-ddclient
@@ -1,12 +1,5 @@
--- ./ddclient.orig 2011-07-25 19:41:39.000000000 -0700
+++ ./ddclient 2011-07-25 19:41:48.000000000 -0700
-@@ -1,5 +1,4 @@
--#!/usr/bin/perl -w
--#!/usr/local/bin/perl -w
-+#!%%PERL%% -w
- ######################################################################
- # $Id: ddclient 157 2013-12-26 09:02:05Z wimpunk $
- #
@@ -19,6 +18,7 @@
use Getopt::Long;
use Sys::Hostname;