aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2015-09-21 15:34:40 +0800
committerashish <ashish@FreeBSD.org>2015-09-21 15:34:40 +0800
commit849e4612c06fc97574718850481ae4adc2285288 (patch)
tree6d16b60c9c10bc68dda69e8e43676887e9960a73 /dns
parent5a09206abc80c035939eb43200d01a53db957961 (diff)
downloadfreebsd-ports-gnome-849e4612c06fc97574718850481ae4adc2285288.tar.gz
freebsd-ports-gnome-849e4612c06fc97574718850481ae4adc2285288.tar.zst
freebsd-ports-gnome-849e4612c06fc97574718850481ae4adc2285288.zip
- Switch to @sample
- Modernize vardir handling PR: 203197 Submitted by: amdmi3
Diffstat (limited to 'dns')
-rw-r--r--dns/pdnsd/Makefile3
-rw-r--r--dns/pdnsd/pkg-install11
-rw-r--r--dns/pdnsd/pkg-plist6
3 files changed, 10 insertions, 10 deletions
diff --git a/dns/pdnsd/Makefile b/dns/pdnsd/Makefile
index f3e17de1df76..43931246c753 100644
--- a/dns/pdnsd/Makefile
+++ b/dns/pdnsd/Makefile
@@ -33,6 +33,9 @@ CFLAGS+= -pthread
IPV6_CONFIGURE_ENABLE= ipv6
+post-install:
+ @${RM} ${STAGEDIR}${PDNSDB}/pdnsd.cache
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${DOC_FILES:S@^@${DOCSRCDIR}/@} ${STAGEDIR}${DOCSDIR}
diff --git a/dns/pdnsd/pkg-install b/dns/pdnsd/pkg-install
index 5dd75a02d92d..95a9adfd797b 100644
--- a/dns/pdnsd/pkg-install
+++ b/dns/pdnsd/pkg-install
@@ -1,9 +1,8 @@
#!/bin/sh
PDNSDB=/var/db/pdnsd
-mkdir -p ${PDNSDB}
-chown nobody ${PDNSDB}
-chmod 755 ${PDNSDB}
-touch ${PDNSDB}/pdnsd.cache
-chown nobody ${PDNSDB}/pdnsd.cache
-chmod 640 ${PDNSDB}/pdnsd.cache
+if [ "${2}" = "POST-INSTALL" ] ; then
+ touch ${PDNSDB}/pdnsd.cache
+ chown nobody ${PDNSDB}/pdnsd.cache
+ chmod 640 ${PDNSDB}/pdnsd.cache
+fi
diff --git a/dns/pdnsd/pkg-plist b/dns/pdnsd/pkg-plist
index fae2a3a15f78..cbe811966246 100644
--- a/dns/pdnsd/pkg-plist
+++ b/dns/pdnsd/pkg-plist
@@ -1,6 +1,4 @@
-@unexec if cmp -s %D/etc/pdnsd.conf %D/etc/pdnsd.conf.sample; then rm %D/etc/pdnsd.conf; fi
-etc/pdnsd.conf.sample
-@exec [ -f %D/etc/pdnsd.conf ] || install -m 644 %D/etc/pdnsd.conf.sample %D/etc/pdnsd.conf
+@sample etc/pdnsd.conf.sample
man/man5/pdnsd.conf.5.gz
man/man8/pdnsd-ctl.8.gz
man/man8/pdnsd.8.gz
@@ -13,4 +11,4 @@ sbin/pdnsd-ctl
%%PORTDOCS%%%%DOCSDIR%%/faq.txt
%%PORTDOCS%%%%DOCSDIR%%/intro.txt
%%PORTDOCS%%%%DOCSDIR%%/manual.txt
-@unexec rm -rf /var/db/pdnsd 2>&1 >/dev/null || true
+@dir(nobody,,755) /var/db/pdnsd