aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-10-07 23:42:10 +0800
committerMathieu Arnold <mat@FreeBSD.org>2019-10-07 23:42:10 +0800
commit9669546782f43df99ad9cbccc3977616a0fd910c (patch)
treef70b9b1e89b8f5b2d0dac415be1c2469102c5c6f /dns
parent9836d990377fc986e72041529943062f834ef33d (diff)
downloadfreebsd-ports-gnome-9669546782f43df99ad9cbccc3977616a0fd910c.tar.gz
freebsd-ports-gnome-9669546782f43df99ad9cbccc3977616a0fd910c.tar.zst
freebsd-ports-gnome-9669546782f43df99ad9cbccc3977616a0fd910c.zip
Update to latest commit.
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/pkg-plist1
4 files changed, 11 insertions, 12 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index cb6e35866311..05fecce83183 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -41,13 +41,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.3a0.2019.09.30
+ISCVERSION= 9.15.4a0.2019.10.06
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 98886bab43fd27d50cca373566c048db4aa373b6
+GL_COMMIT= 38270b790099e0c997da15016cf572e14fe5f9b1
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 51563f486b57..767058086705 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1569848062
-SHA256 (isc-projects-bind9-98886bab43fd27d50cca373566c048db4aa373b6_GL0.tar.gz) = cf4b67a8af3ef79d7c2001c1d528f073114c5098dcbfde990556f69209fdc4e1
-SIZE (isc-projects-bind9-98886bab43fd27d50cca373566c048db4aa373b6_GL0.tar.gz) = 6340999
+TIMESTAMP = 1570446298
+SHA256 (isc-projects-bind9-38270b790099e0c997da15016cf572e14fe5f9b1_GL0.tar.gz) = af6bb3333f6e708fca5fe7ea550a291a6afa0a5ee335f27da61aebab5665c2a5
+SIZE (isc-projects-bind9-38270b790099e0c997da15016cf572e14fe5f9b1_GL0.tar.gz) = 6335854
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 7a4242d55bc5..b41c3d66e6a5 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2019-08-30 19:08:30 UTC
+--- bin/named/config.c.orig 2019-10-06 03:16:14 UTC
+++ bin/named/config.c
@@ -177,6 +177,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-08-30 19:08:30 UTC
+--- bin/named/server.c.orig 2019-10-06 03:16:14 UTC
+++ bin/named/server.c
@@ -4215,6 +4215,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-08-30 19:08:30 UTC
+--- lib/dns/include/dns/view.h.orig 2019-10-06 03:16:14 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-08-30 19:08:30 UTC
+--- lib/dns/resolver.c.orig 2019-10-06 03:16:14 UTC
+++ lib/dns/resolver.c
-@@ -6007,6 +6007,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6028,6 +6028,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-08-30 19:08:30 UTC
+--- lib/isccfg/namedconf.c.orig 2019-10-06 03:16:14 UTC
+++ lib/isccfg/namedconf.c
@@ -1907,6 +1907,7 @@ view_clauses[] = {
#endif
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 142681c10af4..5b273e53e2ad 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -254,7 +254,6 @@ include/pk11/internal.h
include/pk11/pk11.h
include/pk11/result.h
include/pk11/site.h
-include/pkcs11/cryptoki.h
include/pkcs11/eddsa.h
include/pkcs11/pkcs11.h
lib/libbind9.a