aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-09 21:05:14 +0800
committermat <mat@FreeBSD.org>2017-11-09 21:05:14 +0800
commitbeb460607d3eca3f213fbb2a0dfcf9820cdff623 (patch)
tree95d4e65da09cc51fb5f2a224c7448351bf88edf1 /dns
parentdaf61af6ad0a9075cf468f9a1f25fe06d1d6d03b (diff)
downloadfreebsd-ports-gnome-beb460607d3eca3f213fbb2a0dfcf9820cdff623.tar.gz
freebsd-ports-gnome-beb460607d3eca3f213fbb2a0dfcf9820cdff623.tar.zst
freebsd-ports-gnome-beb460607d3eca3f213fbb2a0dfcf9820cdff623.zip
Update to 9.12.0b2.
Sponsored by: Absolight
Diffstat (limited to 'dns')
-rw-r--r--dns/bind912/Makefile6
-rw-r--r--dns/bind912/distinfo6
-rw-r--r--dns/bind912/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind912/files/patch-configure8
-rw-r--r--dns/bind912/pkg-plist4
5 files changed, 20 insertions, 20 deletions
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index 37d543e5f989..bccafe2a3ada 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -5,10 +5,10 @@ PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
-PORTREVISION= 1
+PORTREVISION= 0
.else
# dns/bind9xx here
-PORTREVISION= 2
+PORTREVISION= 0
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -30,7 +30,7 @@ LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.0b1
+ISCVERSION= 9.12.0b2
USES= cpe libedit
diff --git a/dns/bind912/distinfo b/dns/bind912/distinfo
index d57d78caf996..e37d38f73ea6 100644
--- a/dns/bind912/distinfo
+++ b/dns/bind912/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1508945823
-SHA256 (bind-9.12.0b1.tar.gz) = 640549c74d5e1d6e1be3fdee37c5664185becdc8aeda334aeb38afa0b57c9c3c
-SIZE (bind-9.12.0b1.tar.gz) = 9249247
+TIMESTAMP = 1510227060
+SHA256 (bind-9.12.0b2.tar.gz) = 0d3a507ae67de7995a95db64886b5369ca6011fc8b3f082defaf3a879dac8b4c
+SIZE (bind-9.12.0b2.tar.gz) = 9274253
diff --git a/dns/bind912/files/extrapatch-bind-min-override-ttl b/dns/bind912/files/extrapatch-bind-min-override-ttl
index adb342d49a4a..e21edeb8a3a5 100644
--- a/dns/bind912/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind912/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2017-10-16 07:38:34 UTC
+--- bin/named/config.c.orig 2017-11-07 21:48:37 UTC
+++ bin/named/config.c
-@@ -178,12 +178,14 @@ options {\n\
+@@ -176,12 +176,14 @@ options {\n\
max-recursion-queries 75;\n\
max-stale-ttl 604800; /* 1 week */\n\
message-compression yes;\n\
@@ -15,9 +15,9 @@
provide-ixfr true;\n\
query-source address *;\n\
query-source-v6 address *;\n\
---- bin/named/server.c.orig 2017-10-16 07:38:34 UTC
+--- bin/named/server.c.orig 2017-11-07 21:48:37 UTC
+++ bin/named/server.c
-@@ -4044,6 +4044,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4059,6 +4059,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2017-10-16 07:38:34 UTC
+--- lib/dns/include/dns/view.h.orig 2017-11-07 21:48:37 UTC
+++ lib/dns/include/dns/view.h
@@ -145,6 +145,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -45,7 +45,7 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2017-10-16 07:38:34 UTC
+--- lib/dns/resolver.c.orig 2017-11-07 21:48:37 UTC
+++ lib/dns/resolver.c
@@ -5747,6 +5747,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -66,9 +66,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2017-10-16 07:38:34 UTC
+--- lib/isccfg/namedconf.c.orig 2017-11-07 21:48:37 UTC
+++ lib/isccfg/namedconf.c
-@@ -1918,6 +1918,8 @@ view_clauses[] = {
+@@ -1909,6 +1909,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind912/files/patch-configure b/dns/bind912/files/patch-configure
index 8c48cdb111ae..a3862f2226e5 100644
--- a/dns/bind912/files/patch-configure
+++ b/dns/bind912/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-10-16 07:38:34 UTC
+--- configure.orig 2017-11-07 21:48:37 UTC
+++ configure
-@@ -14420,27 +14420,9 @@ done
+@@ -14417,27 +14417,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14483,47 +14465,7 @@ $as_echo "no" >&6; } ;;
+@@ -14480,47 +14462,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23113,7 +23055,7 @@ $as_echo "" >&6; }
+@@ -23121,7 +23063,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind912/pkg-plist b/dns/bind912/pkg-plist
index e53e4a2e03c3..cdd3e74b1d14 100644
--- a/dns/bind912/pkg-plist
+++ b/dns/bind912/pkg-plist
@@ -147,6 +147,7 @@ include/isc/commandline.h
include/isc/condition.h
include/isc/counter.h
include/isc/crc64.h
+include/isc/deprecated.h
include/isc/dir.h
include/isc/entropy.h
include/isc/errno.h
@@ -173,6 +174,7 @@ include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
include/isc/lib.h
+include/isc/likely.h
include/isc/list.h
include/isc/log.h
include/isc/magic.h
@@ -311,7 +313,6 @@ man/man8/dnssec-settime.8.gz
man/man8/dnssec-signzone.8.gz
man/man8/dnssec-verify.8.gz
man/man8/genrandom.8.gz
-man/man8/isc-hmac-fixup.8.gz
man/man8/named-checkconf.8.gz
man/man8/named-checkzone.8.gz
man/man8/named-compilezone.8.gz
@@ -340,7 +341,6 @@ sbin/dnssec-settime
sbin/dnssec-signzone
sbin/dnssec-verify
sbin/genrandom
-sbin/isc-hmac-fixup
sbin/named
sbin/named-checkconf
sbin/named-checkzone