aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2014-04-13 03:43:33 +0800
committersem <sem@FreeBSD.org>2014-04-13 03:43:33 +0800
commitc6527a16d1906be7cfed5dba8cd193659872c5f4 (patch)
tree182a562ecd42b2a3425d3af0e03a9d9f07d8678b /dns
parentb9640e3e6ebfa9e4e964f1a7dc73b38e5314e8e1 (diff)
downloadfreebsd-ports-gnome-c6527a16d1906be7cfed5dba8cd193659872c5f4.tar.gz
freebsd-ports-gnome-c6527a16d1906be7cfed5dba8cd193659872c5f4.tar.zst
freebsd-ports-gnome-c6527a16d1906be7cfed5dba8cd193659872c5f4.zip
- Really fix unbound_anchorflags
- New LIB_DEPENDS format - Strip binaries
Diffstat (limited to 'dns')
-rw-r--r--dns/unbound/Makefile20
-rw-r--r--dns/unbound/files/unbound.in6
2 files changed, 18 insertions, 8 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 53cbdc9e4e09..f9c4cea4848a 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -3,17 +3,17 @@
PORTNAME= unbound
PORTVERSION= 1.4.22
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
MAINTAINER= sem@FreeBSD.org
COMMENT= A validating, recursive, and caching DNS resolver
-LICENSE= BSD
+LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_GMAKE= yes
+USES+= gmake
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ssl=${OPENSSLBASE} --with-libexpat=${LOCALBASE}
@@ -44,8 +44,11 @@ MUNIN_DESC= Install Munin plugin
.include <bsd.port.options.mk>
-LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2 \
- ldns:${PORTSDIR}/dns/ldns
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libldns.so:${PORTSDIR}/dns/ldns
+
+STRIP_FILES= .libs/libunbound.so.4 unbound-checkconf unbound \
+ unbound-control .libs/unbound-host .libs/unbound-anchor
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
@@ -81,10 +84,10 @@ MUNIN= "@comment "
.endif
.if ${PORT_OPTIONS:MLIBEVENT14}
-LIB_DEPENDS+= event-1:${PORTSDIR}/devel/libevent
+LIB_DEPENDS+= libevent-1.4:${PORTSDIR}/devel/libevent
CONFIGURE_ARGS+=--with-libevent=${LOCALBASE}
.elif ${PORT_OPTIONS:MLIBEVENT20}
-LIB_DEPENDS+= event-2:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2
USES+= pkgconfig
CONFIGURE_ARGS+=--with-libevent=${NONEXISTENT}
CONFIGURE_ENV+= found_libevent=yes
@@ -102,6 +105,9 @@ post-patch:
@${MKDIR} ${WRKSRC}/balancer
@${RM} ${WRKSRC}/util/configlexer.c
+post-build:
+ @for s in ${STRIP_FILES}; do ${STRIP_CMD} ${WRKSRC}/$$s; done
+
post-install:
.if ${PORT_OPTIONS:MMUNIN}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/munin/plugins
diff --git a/dns/unbound/files/unbound.in b/dns/unbound/files/unbound.in
index 9218633e8609..94ae92124cd2 100644
--- a/dns/unbound/files/unbound.in
+++ b/dns/unbound/files/unbound.in
@@ -35,7 +35,11 @@ start_precmd()
{
%%PREFIX%%/sbin/unbound-checkconf > /dev/null && \
echo -n "Obtaining a trust anchor:" && \
- su -m unbound -c "%%PREFIX%%/sbin/unbound-anchor ${unbound_anchorflags}" && \
+ if [ "${unbound_anchorflags}T" = "T" ]; then \
+ su -m unbound -c %%PREFIX%%/sbin/unbound-anchor; \
+ else
+ su -m unbound -c "%%PREFIX%%/sbin/unbound-anchor ${unbound_anchorflags}"; \
+ fi &&
echo .
}