aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-02-09 20:11:11 +0800
committerMathieu Arnold <mat@FreeBSD.org>2019-02-09 20:11:11 +0800
commitc999767558c4b31f6e907ea4251d6dc2051658ee (patch)
treee861a9c0c19c7ee4daeb4bbd05be45204269c6f8 /dns
parent1f395301fb730315b812c70c590a99d52abdbab6 (diff)
downloadfreebsd-ports-gnome-c999767558c4b31f6e907ea4251d6dc2051658ee.tar.gz
freebsd-ports-gnome-c999767558c4b31f6e907ea4251d6dc2051658ee.tar.zst
freebsd-ports-gnome-c999767558c4b31f6e907ea4251d6dc2051658ee.zip
Update to 9.13.6.
Diffstat (limited to 'dns')
-rw-r--r--dns/bind913/Makefile16
-rw-r--r--dns/bind913/distinfo6
-rw-r--r--dns/bind913/files/extrapatch-bind-min-override-ttl20
-rw-r--r--dns/bind913/files/patch-bin_named_include_named_globals.h4
-rw-r--r--dns/bind913/files/patch-configure8
-rw-r--r--dns/bind913/pkg-plist4
6 files changed, 23 insertions, 35 deletions
diff --git a/dns/bind913/Makefile b/dns/bind913/Makefile
index 0adc278feded..e32bfa1e52cd 100644
--- a/dns/bind913/Makefile
+++ b/dns/bind913/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
USES= compiler:c11 cpe libedit ssl
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.5
+ISCVERSION= 9.13.6
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -67,14 +67,14 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFAULT= SIGCHASE IDN GSSAPI_NONE JSON PYTHON
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
- FIXED_RRSET SIGCHASE IPV6
+ FIXED_RRSET SIGCHASE
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= NATIVE_PKCS11
.if !defined(BIND_TOOLS_SLAVE)
-OPTIONS_DEFAULT+= DLZ_FILESYSTEM LMDB RPZ_NSDNAME RPZ_NSIP TCP_FASTOPEN
-OPTIONS_DEFINE+= RPZ_NSIP RPZ_NSDNAME DOCS \
+OPTIONS_DEFAULT+= DLZ_FILESYSTEM LMDB TCP_FASTOPEN
+OPTIONS_DEFINE+= DOCS \
MINCACHE PORTREVISION QUERYTRACE LMDB DNSTAP \
START_LATE TUNING_LARGE TCP_FASTOPEN
OPTIONS_GROUP= DLZ
@@ -107,8 +107,6 @@ NATIVE_PKCS11_DESC= Use PKCS\#11 native API (**READ HELP**)
PORTREVISION_DESC= Show PORTREVISION in the version string
PYTHON_DESC= Build with Python utilities
QUERYTRACE_DESC= Enable the very verbose query tracelogging
-RPZ_NSDNAME_DESC= Enable RPZ NSDNAME policy records
-RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
START_LATE_DESC= Start BIND late in the boot process (see help)
TCP_FASTOPEN_DESC= RFC 7413 support
@@ -155,8 +153,6 @@ IDN_CONFIGURE_ON= --with-libidn2=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
IDN_USES= iconv
-IPV6_CONFIGURE_ENABLE= ipv6
-
JSON_CONFIGURE_WITH= libjson=${LOCALBASE}
JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
@@ -176,10 +172,6 @@ PYTHON_USES= python
QUERYTRACE_CONFIGURE_ENABLE= querytrace
-RPZ_NSDNAME_CONFIGURE_ENABLE= rpz-nsdname
-
-RPZ_NSIP_CONFIGURE_ENABLE= rpz-nsip
-
SIGCHASE_CONFIGURE_ON= STD_CDEFINES="-DDIG_SIGCHASE=1"
START_LATE_SUB_LIST= NAMED_REQUIRE="SERVERS cleanvar" \
diff --git a/dns/bind913/distinfo b/dns/bind913/distinfo
index 11226bf191c6..3dcdad233209 100644
--- a/dns/bind913/distinfo
+++ b/dns/bind913/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1544687807
-SHA256 (bind-9.13.5.tar.gz) = bbde0b81c66a7c7f5b074c8f0e714ed8aa235e4b930e28953cab0ae3cae94e4b
-SIZE (bind-9.13.5.tar.gz) = 6309308
+TIMESTAMP = 1549709789
+SHA256 (bind-9.13.6.tar.gz) = ae771f209fd807d6cb9db20e16ee96ec4ba44b2052cda8c4487ddacae124870e
+SIZE (bind-9.13.6.tar.gz) = 6316388
diff --git a/dns/bind913/files/extrapatch-bind-min-override-ttl b/dns/bind913/files/extrapatch-bind-min-override-ttl
index 3cf1c096028b..9a1feb62b454 100644
--- a/dns/bind913/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind913/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-12-07 18:44:21 UTC
+--- bin/named/config.c.orig 2019-02-06 23:44:09 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
@@ -8,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-12-07 18:44:21 UTC
+--- bin/named/server.c.orig 2019-02-06 23:44:09 UTC
+++ bin/named/server.c
-@@ -4154,6 +4154,11 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4150,6 +4150,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-12-07 18:44:21 UTC
+--- lib/dns/include/dns/view.h.orig 2019-02-06 23:44:09 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,7 @@ struct dns_view {
bool requestnsid;
@@ -32,9 +32,9 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2018-12-07 18:44:21 UTC
+--- lib/dns/resolver.c.orig 2019-02-06 23:44:09 UTC
+++ lib/dns/resolver.c
-@@ -5967,6 +5967,12 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -6008,6 +6008,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -47,11 +47,11 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-12-07 18:44:21 UTC
+--- lib/isccfg/namedconf.c.orig 2019-02-06 23:44:09 UTC
+++ lib/isccfg/namedconf.c
-@@ -1900,6 +1900,7 @@ view_clauses[] = {
- { "max-acache-size", &cfg_type_sizenodefault,
- CFG_CLAUSEFLAG_OBSOLETE },
+@@ -1899,6 +1899,7 @@ view_clauses[] = {
+ #endif
+ { "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
+ { "override-cache-ttl", &cfg_type_ttlval, 0 },
{ "max-cache-ttl", &cfg_type_ttlval, 0 },
diff --git a/dns/bind913/files/patch-bin_named_include_named_globals.h b/dns/bind913/files/patch-bin_named_include_named_globals.h
index 50037c03632e..37db6ad04498 100644
--- a/dns/bind913/files/patch-bin_named_include_named_globals.h
+++ b/dns/bind913/files/patch-bin_named_include_named_globals.h
@@ -1,8 +1,8 @@
We reference the pid file as being run/named/pid everywere else.
---- bin/named/include/named/globals.h.orig 2018-09-06 00:15:26 UTC
+--- bin/named/include/named/globals.h.orig 2019-02-06 23:44:09 UTC
+++ bin/named/include/named/globals.h
-@@ -128,7 +128,7 @@ EXTERN bool named_g_forcelock INIT(fals
+@@ -129,7 +129,7 @@ EXTERN bool named_g_forcelock INIT(false);
#if NAMED_RUN_PID_DIR
EXTERN const char * named_g_defaultpidfile INIT(NAMED_LOCALSTATEDIR
"/run/named/"
diff --git a/dns/bind913/files/patch-configure b/dns/bind913/files/patch-configure
index 0a296073985c..b35673e818db 100644
--- a/dns/bind913/files/patch-configure
+++ b/dns/bind913/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-12-07 18:44:21 UTC
+--- configure.orig 2019-02-06 23:44:09 UTC
+++ configure
-@@ -16296,27 +16296,9 @@ done
+@@ -16302,27 +16302,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16359,47 +16341,7 @@ $as_echo "no" >&6; } ;;
+@@ -16365,47 +16347,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -20933,7 +20875,7 @@ $as_echo "" >&6; }
+@@ -20864,7 +20806,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind913/pkg-plist b/dns/bind913/pkg-plist
index 580cc0cf5959..b9699d58e377 100644
--- a/dns/bind913/pkg-plist
+++ b/dns/bind913/pkg-plist
@@ -124,7 +124,6 @@ include/dns/zoneverify.h
include/dns/zt.h
include/dst/dst.h
include/dst/gssapi.h
-include/dst/lib.h
include/dst/result.h
include/irs/context.h
include/irs/dnsconf.h
@@ -177,8 +176,6 @@ include/isc/magic.h
include/isc/md.h
include/isc/mem.h
include/isc/meminfo.h
-include/isc/msgcat.h
-include/isc/msgs.h
include/isc/mutex.h
include/isc/mutexblock.h
include/isc/net.h
@@ -234,7 +231,6 @@ include/isccc/base64.h
include/isccc/cc.h
include/isccc/ccmsg.h
include/isccc/events.h
-include/isccc/lib.h
include/isccc/result.h
include/isccc/sexpr.h
include/isccc/symtab.h