aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-12-09 22:10:35 +0800
committerMathieu Arnold <mat@FreeBSD.org>2019-12-09 22:10:35 +0800
commite27d8ba87e22705a9a036046e9214b763485be15 (patch)
treed54d63c05eca38c131215720c4c877360f694d60 /dns
parentb527e31e9611443fd54a025ed0593daef16ef4f0 (diff)
downloadfreebsd-ports-gnome-e27d8ba87e22705a9a036046e9214b763485be15.tar.gz
freebsd-ports-gnome-e27d8ba87e22705a9a036046e9214b763485be15.tar.zst
freebsd-ports-gnome-e27d8ba87e22705a9a036046e9214b763485be15.zip
Update to latest commit.
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 16 insertions, 16 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index abd5819aafa7..385819396daf 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -42,13 +42,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.5a0.2019.11.12
+ISCVERSION= 9.15.6a0.2019.12.09
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= b4a015ebcda51d5975375d64b662963472df76a0
+GL_COMMIT= edd6a084f0588f3512f48def223f54b6fe75cef0
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 281d96cb181f..06e40cb82913 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1573560175
-SHA256 (isc-projects-bind9-b4a015ebcda51d5975375d64b662963472df76a0_GL0.tar.gz) = 1320b92e42e77d4369fce30b474be5a01bf86394333afcc719bb665fd78d61fc
-SIZE (isc-projects-bind9-b4a015ebcda51d5975375d64b662963472df76a0_GL0.tar.gz) = 6434023
+TIMESTAMP = 1575887188
+SHA256 (isc-projects-bind9-edd6a084f0588f3512f48def223f54b6fe75cef0_GL0.tar.gz) = 9efb2e9a5113e792eb4a83633de0da5612a64f3ba86986b10df4c4c251f0de62
+SIZE (isc-projects-bind9-edd6a084f0588f3512f48def223f54b6fe75cef0_GL0.tar.gz) = 6472037
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 4f9720e083ab..1a7eacbb9cfd 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2019-11-12 11:24:41 UTC
+--- bin/named/config.c.orig 2019-12-09 08:22:56 UTC
+++ bin/named/config.c
@@ -178,6 +178,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-11-12 11:24:41 UTC
+--- bin/named/server.c.orig 2019-12-09 08:22:56 UTC
+++ bin/named/server.c
-@@ -4219,6 +4219,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4354,6 +4354,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2019-11-12 11:24:41 UTC
+--- lib/dns/include/dns/view.h.orig 2019-12-09 08:22:56 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-11-12 11:24:41 UTC
+--- lib/dns/resolver.c.orig 2019-12-09 08:22:56 UTC
+++ lib/dns/resolver.c
-@@ -6056,6 +6056,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6031,6 +6031,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-11-12 11:24:41 UTC
+--- lib/isccfg/namedconf.c.orig 2019-12-09 08:22:56 UTC
+++ lib/isccfg/namedconf.c
@@ -1980,6 +1980,7 @@ view_clauses[] = {
#endif
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 6634ab06f826..5c0dddb2b430 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2019-11-12 11:24:41 UTC
+--- configure.orig 2019-12-09 08:22:56 UTC
+++ configure
-@@ -17414,27 +17414,9 @@ done
+@@ -17422,27 +17422,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17477,47 +17459,7 @@ $as_echo "no" >&6; } ;;
+@@ -17485,47 +17467,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22869,7 +22811,7 @@ $as_echo "" >&6; }
+@@ -23037,7 +22979,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).