aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-04 16:31:46 +0800
committermiwi <miwi@FreeBSD.org>2007-06-04 16:31:46 +0800
commite6bbc2df2a199b6fdaf8fa785e349a5934da9849 (patch)
tree80a4f2ad05f6cec6f5f08efd245ab047da3ca77a /dns
parentdd73effe22db11b52c7b10f459a712d35bd739e6 (diff)
downloadfreebsd-ports-gnome-e6bbc2df2a199b6fdaf8fa785e349a5934da9849.tar.gz
freebsd-ports-gnome-e6bbc2df2a199b6fdaf8fa785e349a5934da9849.tar.zst
freebsd-ports-gnome-e6bbc2df2a199b6fdaf8fa785e349a5934da9849.zip
Manages LDAP entries for the BIND9 SDB LDAP patch.
Supports adding, removing, and modifying enteries. The attributes it can handle are TTL, A record, C name, AAAA record, and MX record. Outside of TTL, multiple attributes for each type record. WWW: http://vvelox.net/projects/ldnsm/ PR: ports/112191 Submitted by: Zane C. Bowers
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/ldnsm/Makefile39
-rw-r--r--dns/ldnsm/distinfo3
-rw-r--r--dns/ldnsm/pkg-descr9
4 files changed, 52 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 81f180463d8f..c636aa6c799a 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -55,6 +55,7 @@
SUBDIR += ipcheck
SUBDIR += ldapdns
SUBDIR += ldns
+ SUBDIR += ldnsm
SUBDIR += libdjbdns
SUBDIR += libidn
SUBDIR += maradns
diff --git a/dns/ldnsm/Makefile b/dns/ldnsm/Makefile
new file mode 100644
index 000000000000..ed9b1f146edf
--- /dev/null
+++ b/dns/ldnsm/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: qar-bufo
+# Date created: 18 April 2007
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldnsm
+PORTVERSION= 0.2.0
+CATEGORIES= dns
+MASTER_SITES= http://vvelox.net/src/ldap/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Manages LDAP enteries for the BIND9 SDB LDAP patch
+
+USE_PERL5= yes
+
+PLIST_FILES= bin/ldnsm
+
+MAN1= ldnsm.1
+
+MAN5= dotldnsm.5
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+#nothing to configure
+do-configure:
+ @${ECHO} -n
+
+#nothing to build
+do-build:
+ @${ECHO} -n
+
+do-install:
+ @${EXEC} cd ${WRKDIR}/${PORTNAME}/ ; ${WRKDIR}/${PORTNAME}/install ${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/dns/ldnsm/distinfo b/dns/ldnsm/distinfo
new file mode 100644
index 000000000000..298c60c153c8
--- /dev/null
+++ b/dns/ldnsm/distinfo
@@ -0,0 +1,3 @@
+MD5 (ldnsm-0.2.0.tgz) = 7e58cb5a9f0acc1e5d63afdfcf30148c
+SHA256 (ldnsm-0.2.0.tgz) = a93b2d14420bf659403d3a03c593a64c23b4ba4219ed388e076dc031df98d435
+SIZE (ldnsm-0.2.0.tgz) = 4371
diff --git a/dns/ldnsm/pkg-descr b/dns/ldnsm/pkg-descr
new file mode 100644
index 000000000000..e5b4f9fbb026
--- /dev/null
+++ b/dns/ldnsm/pkg-descr
@@ -0,0 +1,9 @@
+Manages LDAP entries for the BIND9 SDB LDAP patch.
+
+Supports adding, removing, and modifying enteries.
+
+The attributes it can handle are TTL, A record, C name, AAAA
+record, and MX record. Outside of TTL, multiple attributes
+for each type record.
+
+WWW: http://vvelox.net/projects/ldnsm/