aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2018-11-11 23:59:50 +0800
committercpm <cpm@FreeBSD.org>2018-11-11 23:59:50 +0800
commitf86bb659dcd66c74ffce85ffcc1575d2095989f8 (patch)
treec2b607da9354173e6ac85ca4d9d87958a4322915 /dns
parent4fb51d2b4c97567768ae020bf755b635b9779eca (diff)
downloadfreebsd-ports-gnome-f86bb659dcd66c74ffce85ffcc1575d2095989f8.tar.gz
freebsd-ports-gnome-f86bb659dcd66c74ffce85ffcc1575d2095989f8.tar.zst
freebsd-ports-gnome-f86bb659dcd66c74ffce85ffcc1575d2095989f8.zip
- Fix building against Lua(JIT). The configuration switch change since version 1.3.2.
When building without poudriere, it would always pick LuaJIT over Lua if both are installed, basically ignoring the configuration knob. - Bump PORTREVISION PR: 233142 (based on) Submitted by: Ralf van der Enden <tremere@cainites.net> MFH: 2018Q4
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsdist/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/dns/dnsdist/Makefile b/dns/dnsdist/Makefile
index 430b6b7166ab..958e10fbc930 100644
--- a/dns/dnsdist/Makefile
+++ b/dns/dnsdist/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dnsdist
DISTVERSION= 1.3.3
+PORTREVISION= 1
CATEGORIES= dns net
MASTER_SITES= https://downloads.powerdns.com/releases/ \
LOCAL/cpm
@@ -51,9 +52,10 @@ FSTRM_CONFIGURE_ENABLE= fstrm
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_ENABLE=gnutls
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
LUAJIT_USES_OFF= lua
-LUAJIT_CONFIGURE_WITH= luajit
+LUAJIT_CONFIGURE_ON= --with-lua=luajit
+LUAJIT_CONFIGURE_OFF= --with-lua=lua-${LUA_VER}
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_ENABLE=libssl