aboutsummaryrefslogtreecommitdiffstats
path: root/editors/biew/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-03-24 08:09:50 +0800
committerMichael Haro <mharo@FreeBSD.org>2000-03-24 08:09:50 +0800
commit837a4626c4d65380bf7bc51703e152c18c640f80 (patch)
tree290d080245ad8a2318924a92774263f330b1f64f /editors/biew/Makefile
parenta05a46eb47637d0925a4d89ec48bdd511defebc2 (diff)
downloadfreebsd-ports-gnome-837a4626c4d65380bf7bc51703e152c18c640f80.tar.gz
freebsd-ports-gnome-837a4626c4d65380bf7bc51703e152c18c640f80.tar.zst
freebsd-ports-gnome-837a4626c4d65380bf7bc51703e152c18c640f80.zip
- Support PREFIX properly
- Fix pkg/PLIST - Add WWW: line into pkg/DESCR PR: 17570 Submitted by: tkato@prontomail.ne.jp
Diffstat (limited to 'editors/biew/Makefile')
-rw-r--r--editors/biew/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 725bb2c19133..5d48b51c67c5 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -26,6 +26,10 @@ MAKE_ARGS+= "CSYSFLAGS=-D__FreeBSD_version=${OSVERSION} -I${LOCALBASE}/include"
MAKE_ARGS+= "OSLDEF=-L${LOCALBASE}/lib"
.endif
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" \
+ ${WRKSRC}/lib/sysdep/generic/unix/os_dep.c
+
pre-build:
${LN} -sf ${WRKSRC}/makefile ${WRKSRC}/Makefile
@@ -40,8 +44,8 @@ post-build:
${LN} -sf ../tools/lzss/lzss ./;./biewhlp biewhlp.prj)
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/biew ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/biew ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/share/biew
- @ ${INSTALL_DATA} ${WRKSRC}/hlp/biew.hlp ${PREFIX}/share/biew
+ ${INSTALL_DATA} ${WRKSRC}/hlp/biew.hlp ${PREFIX}/share/biew
.include <bsd.port.post.mk>