aboutsummaryrefslogtreecommitdiffstats
path: root/editors/calligra/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-04-28 17:28:46 +0800
committertcberner <tcberner@FreeBSD.org>2018-04-28 17:28:46 +0800
commitbd4bb0070cd96c827ee9c27578c0370e546db63d (patch)
tree9b929f8d639fd7a0548bb4d67fe90d5e34ae90cb /editors/calligra/Makefile
parent06738316ef1ce4a71f1a612a581283cc4ac99d51 (diff)
downloadfreebsd-ports-gnome-bd4bb0070cd96c827ee9c27578c0370e546db63d.tar.gz
freebsd-ports-gnome-bd4bb0070cd96c827ee9c27578c0370e546db63d.tar.zst
freebsd-ports-gnome-bd4bb0070cd96c827ee9c27578c0370e546db63d.zip
Update calligra, krita, kexi (and their dependencies) to their newest versions
Diffstat (limited to 'editors/calligra/Makefile')
-rw-r--r--editors/calligra/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 7c204dd9bed0..9a226f7d941a 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -1,12 +1,7 @@
# $FreeBSD$
-# TODO (when these parts are available in KF5):
-# - add calendarcore to USE_KDE when KDE PIM is available
-# - add libOkular5Core.so:graphics/okular to LIB_DEPENDS
-#
PORTNAME= calligra
-PORTVERSION= 3.0.1
-PORTREVISION= 10
+DISTVERSION= 3.1.0
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -49,7 +44,8 @@ USE_KDE= activities archive auth bookmarks codecs completion config \
jobwidgets js kcmutils kdelibs4support khtml kio \
kross notifications notifyconfig parts service solid sonnet \
texteditor textwidgets threadweaver unitconversion wallet \
- widgetsaddons windowsystem xmlgui
+ widgetsaddons windowsystem xmlgui \
+ calendarcore okular
USE_QT5= buildtools_build core dbus gui network opengl \
phonon4 printsupport qmake_build qml \
quick script sql svg testlib webkit widgets x11extras xml
@@ -60,19 +56,16 @@ OPTIONS_DEFINE= OPENEXR
OPTIONS_DEFAULT= OPENEXR
OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR
+OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DPRODUCTSET:STRING="DESKTOP"
# Requested by upstream, to not include unfinished modules
-CMAKE_ARGS+= -DRELEASE_BUILD:BOOL=TRUE
+CMAKE_ON= RELEASE_BUILD
# Performance increase according to README.PACKAGERS
CMAKE_ARGS+= -DCMAKE_CXX_FLAGS="-DKDE_NO_DEBUG_OUTPUT"
-# Disable KDE Pim support
-CMAKE_ARGS+= -DCMAKE_DISABLE_FIND_PACKAGE_KF5Akonadi:BOOL=FALSE \
- -DCMAKE_DISABLE_FIND_PACKAGE_KF5AkonadiContact:BOOL=FALSE
-
-PLIST_SUB+= SHLIB_VER=15.0.0
+PLIST_SUB+= SHLIB_VER=16.0.0
.include <bsd.port.mk>