aboutsummaryrefslogtreecommitdiffstats
path: root/editors/codelite/files
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
committertijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
commitf8357b5cbaa160ccdf9943cac099f5e092c591da (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /editors/codelite/files
parent89a7d6ecbdde724b92ca6650493f56cf68855f35 (diff)
downloadfreebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.gz
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.zst
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'editors/codelite/files')
-rw-r--r--editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt b/editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt
new file mode 100644
index 000000000000..aed26e91dd3d
--- /dev/null
+++ b/editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- sdk/codelite_indexer/CMakeLists.txt.orig
++++ sdk/codelite_indexer/CMakeLists.txt
+@@ -33,7 +33,7 @@
+
+ # Define the output
+ add_executable(codelite_indexer ${SRCS})
+-target_link_libraries(codelite_indexer ${LINKER_OPTIONS} ${wxWidgets_LIBRARIES})
++target_link_libraries(codelite_indexer ${LINKER_OPTIONS} ${wxWidgets_LIBRARIES} -pthread)
+
+ install(TARGETS codelite_indexer DESTINATION ${CL_PREFIX}/bin)
+