aboutsummaryrefslogtreecommitdiffstats
path: root/editors/drjava/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-01 15:46:46 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-01 15:46:46 +0800
commit67a4fc00b23f36318165ff80328153a4e0973482 (patch)
treeef9fa9912c718a72bad258e0fa7b25fe5a1a78b9 /editors/drjava/Makefile
parentb8492ea3b07eeb1914fd14fa376f9bed7600d4ae (diff)
downloadfreebsd-ports-gnome-67a4fc00b23f36318165ff80328153a4e0973482.tar.gz
freebsd-ports-gnome-67a4fc00b23f36318165ff80328153a4e0973482.tar.zst
freebsd-ports-gnome-67a4fc00b23f36318165ff80328153a4e0973482.zip
DrJava is a lightweight development environment for writing Java programs.
It is designed primarily for students, providing an intuitive interface and the ability to interactively evaluate Java code. It also includes powerful features for more advanced users. DrJava is available for free under the DrJava Open Source License, and it is under active development by the JavaPLT group at Rice University. WWW: http://www.drjava.org PR: ports/95712 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'editors/drjava/Makefile')
-rw-r--r--editors/drjava/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/editors/drjava/Makefile b/editors/drjava/Makefile
new file mode 100644
index 000000000000..b90bd63b95a8
--- /dev/null
+++ b/editors/drjava/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: drjava
+# Date created: 2006-04-13
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drjava
+PORTVERSION= 20060127.2145
+CATEGORIES= editors java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-stable-${PORTVERSION:S|.|-|g}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= nivit@email.it
+COMMENT= A lightweight IDE for writing Java programs
+
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+
+SUB_FILES= ${PORTNAME}
+SUB_LIST= DRJAVAJAR=${DRJAVAJAR}
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+DRJAVAJAR= ${DATADIR}/${DISTFILES}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${DRJAVAJAR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>