aboutsummaryrefslogtreecommitdiffstats
path: root/editors/emacs21
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2001-11-17 11:41:07 +0800
committerkuriyama <kuriyama@FreeBSD.org>2001-11-17 11:41:07 +0800
commit0abcf6cb9341220fd4aa23b67c4273ed8c653f9e (patch)
tree013c47168da0d233f5b31046dd945909c689bfcd /editors/emacs21
parent666d45fb4445c90ce141193b1c3c5dd122c5a40c (diff)
downloadfreebsd-ports-gnome-0abcf6cb9341220fd4aa23b67c4273ed8c653f9e.tar.gz
freebsd-ports-gnome-0abcf6cb9341220fd4aa23b67c4273ed8c653f9e.tar.zst
freebsd-ports-gnome-0abcf6cb9341220fd4aa23b67c4273ed8c653f9e.zip
Fix to make vc-backup file only if vc-make-backup-files is t.
Use (make-backup-file-name-1) to reflect backup-directory-alist in vc-mode.
Diffstat (limited to 'editors/emacs21')
-rw-r--r--editors/emacs21/Makefile2
-rw-r--r--editors/emacs21/files/patch-lisp:vc-hooks.el24
2 files changed, 25 insertions, 1 deletions
diff --git a/editors/emacs21/Makefile b/editors/emacs21/Makefile
index 23536992983b..9c904a745dfb 100644
--- a/editors/emacs21/Makefile
+++ b/editors/emacs21/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emacs
PORTVERSION= 21.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/editors/emacs21/files/patch-lisp:vc-hooks.el b/editors/emacs21/files/patch-lisp:vc-hooks.el
new file mode 100644
index 000000000000..8675c85f9e37
--- /dev/null
+++ b/editors/emacs21/files/patch-lisp:vc-hooks.el
@@ -0,0 +1,24 @@
+--- lisp/vc-hooks.el.orig Mon Nov 12 23:37:38 2001
++++ lisp/vc-hooks.el Tue Nov 13 12:56:08 2001
+@@ -475,10 +475,9 @@
+ (if regexp
+ (concat (regexp-quote (file-name-nondirectory file))
+ "\\.~[0-9.]+" (unless manual "\\.") "~")
+- (expand-file-name (concat (file-name-nondirectory file)
+- ".~" (or rev (vc-workfile-version file))
+- (unless manual ".") "~")
+- (file-name-directory file))))
++ (concat (make-backup-file-name-1 file)
++ ".~" (or rev (vc-workfile-version file))
++ (unless manual ".") "~")))
+
+ (defun vc-delete-automatic-version-backups (file)
+ "Delete all existing automatic version backups for FILE."
+@@ -509,6 +508,7 @@
+ (vc-up-to-date-p file)
+ (eq (vc-checkout-model file) 'implicit)
+ (vc-call make-version-backups-p file)
++ vc-make-backup-files
+ (vc-make-version-backup file))))
+
+ (defun vc-after-save ()