aboutsummaryrefslogtreecommitdiffstats
path: root/editors/focuswriter/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
commitf6763c3cd1541b5d51cd003610210be9e3f57b92 (patch)
treec9a458d29164af55be5bf3330f3f659428ac04ac /editors/focuswriter/Makefile
parentffc02588e890cf8d01b2305cfb96dbb0eaf038a8 (diff)
downloadfreebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.gz
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.zst
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Diffstat (limited to 'editors/focuswriter/Makefile')
-rw-r--r--editors/focuswriter/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/editors/focuswriter/Makefile b/editors/focuswriter/Makefile
index 49490450cfe5..ea1778aac331 100644
--- a/editors/focuswriter/Makefile
+++ b/editors/focuswriter/Makefile
@@ -31,26 +31,15 @@ PORTDOCS= CREDITS NEWS README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e '/INSTALLS/s/man //' \
${WRKSRC}/focuswriter.pro
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
- @${REINPLACE_CMD} -e 's/std::lround/lround/g' \
- ${WRKSRC}/src/daily_progress_dialog.cpp \
- ${WRKSRC}/src/scene_list.cpp \
- ${WRKSRC}/src/theme_dialog.cpp \
- ${WRKSRC}/src/fileformats/docx_reader.cpp \
- ${WRKSRC}/src/fileformats/odt_reader.cpp \
- ${WRKSRC}/src/fileformats/rtf_reader.cpp
-.endif
-
-do-install-DOCS-on:
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
post-install:
${INSTALL_MAN} ${WRKSRC}/resources/unix/focuswriter.1 \
${STAGEDIR}${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+post-install-DOCS-on:
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>