aboutsummaryrefslogtreecommitdiffstats
path: root/editors/ghex/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-11-27 03:43:35 +0800
committersteve <steve@FreeBSD.org>1999-11-27 03:43:35 +0800
commita3179fc0ea95cd0ad2b3764e818f415dc6348767 (patch)
tree1b797b2b7d3ceac8c994d513a75fbae11580059e /editors/ghex/Makefile
parent6ff0fb6f69258c70d7b9d36b9ba47349cbb6a449 (diff)
downloadfreebsd-ports-gnome-a3179fc0ea95cd0ad2b3764e818f415dc6348767.tar.gz
freebsd-ports-gnome-a3179fc0ea95cd0ad2b3764e818f415dc6348767.tar.zst
freebsd-ports-gnome-a3179fc0ea95cd0ad2b3764e818f415dc6348767.zip
Initial import of ghex version 1.0.1.3.
A GNOME hex editor. PR: 14570 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
Diffstat (limited to 'editors/ghex/Makefile')
-rw-r--r--editors/ghex/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/editors/ghex/Makefile b/editors/ghex/Makefile
new file mode 100644
index 000000000000..9f151bdc1ecf
--- /dev/null
+++ b/editors/ghex/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ghex
+# Version required: 1.0.1.3
+# Date created: 07 August 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= ghex-1.0.1.3
+CATEGORIES= editors gnome
+MASTER_SITES= http://pluton.ijs.si/~jaka/
+
+MAINTAINER= jedgar@fxp.org
+
+LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-x
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>