aboutsummaryrefslogtreecommitdiffstats
path: root/editors/ghostwriter/Makefile
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-08-03 14:58:31 +0800
committertobik <tobik@FreeBSD.org>2018-08-03 14:58:31 +0800
commit1a84905031c983afafa36b42330a64d74429af4e (patch)
treec97ad96f5d11a64e1081dcac249c49b9a344f0cd /editors/ghostwriter/Makefile
parent51ce5060eec8afb155bcf3a057fbb28821479d95 (diff)
downloadfreebsd-ports-gnome-1a84905031c983afafa36b42330a64d74429af4e.tar.gz
freebsd-ports-gnome-1a84905031c983afafa36b42330a64d74429af4e.tar.zst
freebsd-ports-gnome-1a84905031c983afafa36b42330a64d74429af4e.zip
New port: editors/ghostwriter
Ghostwriter is a text editor for Markdown. It provides a relaxing, distraction-free writing environment, whether your masterpiece is that next blog post, your school paper, or your NaNoWriMo novel. Create your own custom themes, write in fullscreen mode, or use focus mode to concentrate on just one or more lines. A live HTML preview allows you to view the final formatting as you type. WWW: http://wereturtle.github.io/ghostwriter/
Diffstat (limited to 'editors/ghostwriter/Makefile')
-rw-r--r--editors/ghostwriter/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/editors/ghostwriter/Makefile b/editors/ghostwriter/Makefile
new file mode 100644
index 000000000000..c3eb1cfc10d2
--- /dev/null
+++ b/editors/ghostwriter/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= ghostwriter
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.2
+CATEGORIES= editors
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Distraction-free Markdown editor
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
+
+USES= desktop-file-utils pkgconfig qmake qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= wereturtle
+USE_QT= concurrent core gui network printsupport svg webkit widgets \
+ buildtools_build linguisttools_build
+LDFLAGS+= -Wl,--as-needed # cf. PR 224488
+
+post-patch:
+ @${REINPLACE_CMD} 's,share/man/,man/,' ${WRKSRC}/ghostwriter.pro
+
+.include <bsd.port.mk>