aboutsummaryrefslogtreecommitdiffstats
path: root/editors/hexedit/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-01-11 02:58:32 +0800
committersteve <steve@FreeBSD.org>1999-01-11 02:58:32 +0800
commit46a133a9cb60a8ddd341a6fcb1cc0ecd374bc3e7 (patch)
treedde6ecdfb6b83a0386e32e62e1a34bda4d631d66 /editors/hexedit/Makefile
parent6cd6c927ccdd1dce5e4fc3fd58f60f5c7bd0e179 (diff)
downloadfreebsd-ports-gnome-46a133a9cb60a8ddd341a6fcb1cc0ecd374bc3e7.tar.gz
freebsd-ports-gnome-46a133a9cb60a8ddd341a6fcb1cc0ecd374bc3e7.tar.zst
freebsd-ports-gnome-46a133a9cb60a8ddd341a6fcb1cc0ecd374bc3e7.zip
Update to version 1.0.0 and use ncurses in the base system.
PR: 9121 Submitted by: maintainer
Diffstat (limited to 'editors/hexedit/Makefile')
-rw-r--r--editors/hexedit/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/editors/hexedit/Makefile b/editors/hexedit/Makefile
index 79486592d8f2..4a4976e300f0 100644
--- a/editors/hexedit/Makefile
+++ b/editors/hexedit/Makefile
@@ -1,30 +1,32 @@
# New ports collection makefile for: hexedit
-# Version required: 0.9.3
+# Version required: 1.0.0
# Date created: 5 August 1998
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.2 1998/08/20 09:39:06 asami Exp $
+# $Id: Makefile,v 1.3 1998/10/09 10:05:49 asami Exp $
#
-DISTNAME= hexedit-0.9.3
-CATEGORIES= editors
-MASTER_SITES= http://www.chez.com/prigaux/
-EXTRACT_SUFX= .src.tgz
+DISTNAME= hexedit-1.0.0
+CATEGORIES= editors
+MASTER_SITES= http://www.chez.com/prigaux/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= utils/file/hex
+EXTRACT_SUFX= .src.tgz
-MAINTAINER= andy@icc.surw.chel.su
+MAINTAINER= andy@icc.surw.chel.su
-LIB_DEPENDS= ncurses.4:${PORTSDIR}/devel/ncurses
-
-MANUAL_PACKAGE_BUILD= depends on ncurses
+USE_AUTOCONF= yes
ALL_TARGET=
-WRKSRC= ${WRKDIR}/hexedit
+WRKSRC= ${WRKDIR}/hexedit
-MAN1= hexedit.1
+MAN1= hexedit.1
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/hexedit ${PREFIX}/bin
@ ${INSTALL_MAN} ${WRKSRC}/hexedit.1 ${PREFIX}/man/man1
+
+post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/hexedit
.for file in COPYING Changes TODO