aboutsummaryrefslogtreecommitdiffstats
path: root/editors/kate-plugin-pate
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /editors/kate-plugin-pate
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'editors/kate-plugin-pate')
-rw-r--r--editors/kate-plugin-pate/Makefile36
-rw-r--r--editors/kate-plugin-pate/pkg-descr3
-rw-r--r--editors/kate-plugin-pate/pkg-plist43
3 files changed, 82 insertions, 0 deletions
diff --git a/editors/kate-plugin-pate/Makefile b/editors/kate-plugin-pate/Makefile
new file mode 100644
index 000000000000..484c8cf4d1ca
--- /dev/null
+++ b/editors/kate-plugin-pate/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= kate-plugin-pate
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= editors kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DISTNAME= kate-${PORTVERSION}
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Support for Python plugins in Kate
+
+USE_XZ= yes
+USES= cmake:outsource
+USE_KDE4= kdelibs kdeprefix kdehier automoc4 kate \
+ pykde4_build pykde4_run
+USE_QT4= gui webkit \
+ moc_build qmake_build rcc_build uic_build
+USE_PYTHON= yes
+MAKE_JOBS_SAFE= yes
+
+DISTINFO_FILE= ${PORTSDIR}/editors/kate/distinfo
+
+# cmake.mk doesn't allow to overwrite BUILD_WRKSRC for out-of-source builds
+_pate_WRKSRC= ${BUILD_WRKSRC}/kate/plugins/pate
+
+do-build:
+ cd ${_pate_WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}
+
+do-install:
+ cd ${_pate_WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
+
+.include <bsd.port.mk>
diff --git a/editors/kate-plugin-pate/pkg-descr b/editors/kate-plugin-pate/pkg-descr
new file mode 100644
index 000000000000..03b98b12bd24
--- /dev/null
+++ b/editors/kate-plugin-pate/pkg-descr
@@ -0,0 +1,3 @@
+Pate is a Kate plugin which provides support for Python plugins.
+
+WWW: https://github.com/pag/pate/
diff --git a/editors/kate-plugin-pate/pkg-plist b/editors/kate-plugin-pate/pkg-plist
new file mode 100644
index 000000000000..d3c1e15c274e
--- /dev/null
+++ b/editors/kate-plugin-pate/pkg-plist
@@ -0,0 +1,43 @@
+lib/kde4/pateplugin.so
+%%PYTHON_SITELIBDIR%%/PyKate4/__init__.py
+%%PYTHON_SITELIBDIR%%/PyKate4/kate.so
+share/apps/kate/pate/block.py
+share/apps/kate/pate/close_tag.py
+share/apps/kate/pate/commentar.py
+share/apps/kate/pate/console/config.ui
+share/apps/kate/pate/console/console.py
+share/apps/kate/pate/expand.py
+share/apps/kate/pate/expand/all.expand
+share/apps/kate/pate/expand/text_css.expand
+share/apps/kate/pate/expand/text_html.expand
+share/apps/kate/pate/expand/text_x-c++hdr.expand
+share/apps/kate/pate/expand/text_x-c++src.expand
+share/apps/kate/pate/expand/text_x-chdr.expand
+share/apps/kate/pate/expand/text_x-python.expand
+share/apps/kate/pate/format.py
+share/apps/kate/pate/gid/config.ui
+share/apps/kate/pate/gid/gid.py
+share/apps/kate/pate/gid/idutils.py
+share/apps/kate/pate/gid/tool.ui
+share/apps/kate/pate/libkatepate/__init__.py
+share/apps/kate/pate/libkatepate/common.py
+share/apps/kate/pate/libkatepate/decorators.py
+share/apps/kate/pate/libkatepate/pred.py
+share/apps/kate/pate/libkatepate/selection.py
+share/apps/kate/pate/libkatepate/ui.py
+share/apps/kate/pate/tools.py
+share/apps/kate/plugins/pate/kate/__init__.py
+share/apps/kate/plugins/pate/kate/gui.py
+share/kde4/services/pate.desktop
+@dirrm share/apps/kate/plugins/pate/kate
+@dirrm share/apps/kate/plugins/pate
+@dirrm share/apps/kate/plugins
+@dirrm share/apps/kate/pate/libkatepate
+@dirrm share/apps/kate/pate/gid
+@dirrm share/apps/kate/pate/expand
+@dirrm share/apps/kate/pate/console
+@dirrm share/apps/kate/pate
+@dirrm share/apps/kate
+@dirrm %%PYTHON_SITELIBDIR%%/PyKate4
+@dirrmtry %%PYTHON_SITELIBDIR%%
+@dirrmtry %%PYTHON_LIBDIR%%