aboutsummaryrefslogtreecommitdiffstats
path: root/editors/neovim
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /editors/neovim
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'editors/neovim')
-rw-r--r--editors/neovim/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 92d8d2daee1a..3c65bdab34b5 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libluajit-5.1.so:lang/luajit \
libuv.so:devel/libuv \
libvterm.so:devel/libvterm
-USES= cmake:outsource iconv lua:build pathfix pkgconfig
+USES= cmake iconv lua:build pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
libmpack:libmpack-lua:1.0.7:libmpack_lua