aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-1.1-devel/Makefile
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2003-03-12 09:04:08 +0800
committermbr <mbr@FreeBSD.org>2003-03-12 09:04:08 +0800
commit00f0af247692800f9036d0b843d01ade3dc1c6f8 (patch)
treec684a6c363a27aefedafd2dfd970449f3e68f4b5 /editors/openoffice-1.1-devel/Makefile
parentc7bf2528c31ea2b1bd64de93b156d0371fd8cd13 (diff)
downloadfreebsd-ports-gnome-00f0af247692800f9036d0b843d01ade3dc1c6f8.tar.gz
freebsd-ports-gnome-00f0af247692800f9036d0b843d01ade3dc1c6f8.tar.zst
freebsd-ports-gnome-00f0af247692800f9036d0b843d01ade3dc1c6f8.zip
Update to cws_srx644_ooo11beta. It still doesn't build but this commit will help
to track the things down. There are known problems with weak symbols and exceptions. Some c++ tools inside the port will fail if you try to compile. The cpp_uno bridge has been updated to the latest linux version available. Added 'make update' target to upgrade the source to the latest version. Approved by: kris (portmgr)
Diffstat (limited to 'editors/openoffice-1.1-devel/Makefile')
-rw-r--r--editors/openoffice-1.1-devel/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 64c08be99f88..6f740924c399 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -8,7 +8,8 @@
PORTNAME= openoffice
PORTVERSION= 644
CATEGORIES+= editors
-MASTER_SITES+= http://ny1.mirror.openoffice.org/developer/%SUBDIR%/ \
+MASTER_SITES+= http://projects.imp.ch/openoffice/%SUBDIR%/ \
+ http://ny1.mirror.openoffice.org/developer/%SUBDIR%/ \
http://ftp.gwdg.de/pub/misc/openoffice/developer/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,developer/%SUBDIR%,misc/openoffice/&,} \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
@@ -567,4 +568,13 @@ package-rename:
${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz2
.endif
+update:
+ @${MAKE} fetch
+ @${MAKE} extract
+ @cd ${WRKSRC}/.. && for dir in *; do \
+ if [ -d $$dir ]; then \
+ cd $$dir; cvs update -d; cd ..; \
+ fi \
+ done
+
.include <bsd.port.post.mk>