aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice-1.1-devel/Makefile
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-03-09 07:06:20 +0800
committermbr <mbr@FreeBSD.org>2002-03-09 07:06:20 +0800
commit32e11038ed49d07bd3b0b2bb59d5dbbb075bf5dd (patch)
tree734bc0baa27025c6ced5d0c67d8a48869140f292 /editors/openoffice-1.1-devel/Makefile
parentfd82036ae168884e3db3fbded419f5e854778b43 (diff)
downloadfreebsd-ports-gnome-32e11038ed49d07bd3b0b2bb59d5dbbb075bf5dd.tar.gz
freebsd-ports-gnome-32e11038ed49d07bd3b0b2bb59d5dbbb075bf5dd.tar.zst
freebsd-ports-gnome-32e11038ed49d07bd3b0b2bb59d5dbbb075bf5dd.zip
Use autoconf, remove the ugly configure patch. Do the gcc tests and fix them
while we are here (AWK had an endless loop), add a FreeBSD configure variable called with-os-version, so we can check the OSVERSION in the build to support both STABLE and CURRENT (there are different patches needed)
Diffstat (limited to 'editors/openoffice-1.1-devel/Makefile')
-rw-r--r--editors/openoffice-1.1-devel/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 2f81232898a1..af9fd994daf2 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -35,10 +35,12 @@ BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
BUILD_DEPENDS+= pth-config:${PORTSDIR}/devel/pth
GNU_CONFIGURE= yes
+USE_AUTOCONF= yes
WRKSRC= ${WRKDIR}/oo_${PORTVERSION}_src/config_office
CONFIGURE_ARGS+= --with-stlport4-home=${PREFIX} \
- --with-jdk-home=${JDK13DIR}
+ --with-jdk-home=${JDK13DIR} \
+ --with-os-version=${OSVERSION}
.include <bsd.port.pre.mk>