aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice.org-2-RC
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-06-15 04:30:38 +0800
committermaho <maho@FreeBSD.org>2009-06-15 04:30:38 +0800
commit5b919da99f377b5bb5e78dd03ee33ff5581c7fef (patch)
tree97f92eb2a1d98a0d28b351e6bfc0a293e5947578 /editors/openoffice.org-2-RC
parentf64de15e56c9d8c743eb4a4dbb443f7afc721637 (diff)
downloadfreebsd-ports-gnome-5b919da99f377b5bb5e78dd03ee33ff5581c7fef.tar.gz
freebsd-ports-gnome-5b919da99f377b5bb5e78dd03ee33ff5581c7fef.tar.zst
freebsd-ports-gnome-5b919da99f377b5bb5e78dd03ee33ff5581c7fef.zip
Fix bad transfer url when tries to add extension.
PR: 127946 see also http://www.openoffice.org/issues/show_bug.cgi?id=98781 http://www.openoffice.org/issues/show_bug.cgi?id=82690 http://www.freebsd.org/cgi/query-pr.cgi?pr=127946 Submitted by : many
Diffstat (limited to 'editors/openoffice.org-2-RC')
-rw-r--r--editors/openoffice.org-2-RC/Makefile2
-rw-r--r--editors/openoffice.org-2-RC/files/patch-i8512626
-rw-r--r--editors/openoffice.org-2-RC/files/patch-i9878124
3 files changed, 51 insertions, 1 deletions
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 3b71264cb23f..ef96db590cc3 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= openoffice.org
PORTVERSION?= 2.4.${SNAPDATE}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES+= editors java
MASTER_SITES+= http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
http://openoffice.lunarshells.com/sources/ \
diff --git a/editors/openoffice.org-2-RC/files/patch-i85126 b/editors/openoffice.org-2-RC/files/patch-i85126
index f70616a998e1..c6bb6410bcb4 100644
--- a/editors/openoffice.org-2-RC/files/patch-i85126
+++ b/editors/openoffice.org-2-RC/files/patch-i85126
@@ -1,4 +1,8 @@
Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
+also fixes
+http://www.openoffice.org/issues/show_bug.cgi?id=98781
+http://www.openoffice.org/issues/show_bug.cgi?id=82690
+http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 16 Sep 2006 15:46:23 -0000 1.3
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 8 Jan 2008 16:57:00 -0000
@@ -117,3 +121,25 @@ Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
VtableSlot aVtableSlot(
getVtableSlot(
reinterpret_cast<
+
+
+--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2008-02-04 22:43:50.000000000 +0900
++++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 2009-06-13 21:41:29.000000000 +0900
+@@ -126,7 +126,7 @@
+ };
+ //__________________________________________________________________________________________________
+ RTTI::RTTI() SAL_THROW( () )
+-#if __FreeBSD_version < 602103
++#ifdef FREEBSD /* #i22253# */
+ : m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
+ #else
+ : m_hApp( dlopen( 0, RTLD_LAZY ) )
+@@ -165,7 +165,7 @@
+ buf.append( 'E' );
+
+ OString symName( buf.makeStringAndClear() );
+-#if __FreeBSD_version < 602103 /* #i22253# */
++#ifdef FREEBSD /* #i22253# */
+ rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
+ #else
+ rtti = (type_info *)dlsym( m_hApp, symName.getStr() );
diff --git a/editors/openoffice.org-2-RC/files/patch-i98781 b/editors/openoffice.org-2-RC/files/patch-i98781
new file mode 100644
index 000000000000..90f951045aa8
--- /dev/null
+++ b/editors/openoffice.org-2-RC/files/patch-i98781
@@ -0,0 +1,24 @@
+http://www.openoffice.org/issues/show_bug.cgi?id=98781
+http://www.openoffice.org/issues/show_bug.cgi?id=82690
+http://www.freebsd.org/cgi/query-pr.cgi?pr=127946
+
+--- bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-14 07:53:52.000000000 +0900
++++ bridges/source/cpp_uno/gcc3_freebsd_intel/except.cxx 2009-06-14 07:56:37.000000000 +0900
+@@ -126,7 +126,7 @@
+ };
+ //__________________________________________________________________________________________________
+ RTTI::RTTI() SAL_THROW( () )
+-#if __FreeBSD_version < 602103
++#ifdef FREEBSD /* #i22253# */
+ : m_hApp( dlopen( 0, RTLD_NOW | RTLD_GLOBAL ) )
+ #else
+ : m_hApp( dlopen( 0, RTLD_LAZY ) )
+@@ -165,7 +165,7 @@
+ buf.append( 'E' );
+
+ OString symName( buf.makeStringAndClear() );
+-#if __FreeBSD_version < 602103 /* #i22253# */
++#ifdef FREEBSD /* #i22253# */
+ rtti = (type_info *)dlsym( RTLD_DEFAULT, symName.getStr() );
+ #else
+ rtti = (type_info *)dlsym( m_hApp, symName.getStr() );