aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-09-09 00:02:39 +0800
committermbr <mbr@FreeBSD.org>2002-09-09 00:02:39 +0800
commit815ecc8ffd624bb0baf6862fa88cd591de5dd3eb (patch)
tree3ba3914112dc056d40d79bcd8a8dd031ffb2f9d5 /editors/openoffice
parent573328ad17bfc3ead78e064ebc0153bdd56c0186 (diff)
downloadfreebsd-ports-gnome-815ecc8ffd624bb0baf6862fa88cd591de5dd3eb.tar.gz
freebsd-ports-gnome-815ecc8ffd624bb0baf6862fa88cd591de5dd3eb.tar.zst
freebsd-ports-gnome-815ecc8ffd624bb0baf6862fa88cd591de5dd3eb.zip
Issue a warning if procfs is not mounted. This is a linuxism
we will remove soon, there is absolutly no reason that OO.org needs a running procfs. Unfortunatly OO.org does segfault at the moment without procfs, so this commit will make the live of some people easier. In CURRENT, procfs is disabled now by default ... Note that ${AWK}, ${GREP} etc are defined in the post section of our bsd.port.mk and need to be redefined to work. Requested indirectly by: mwlucas (who suffered a lot)
Diffstat (limited to 'editors/openoffice')
-rw-r--r--editors/openoffice/Makefile20
-rw-r--r--editors/openoffice/pkg-message8
2 files changed, 28 insertions, 0 deletions
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index d892c463fef7..5a825976955b 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -22,9 +22,13 @@ DISTFILES+= ${L10NHELP:S/$/:help/}
SORT?= /usr/bin/sort
CUT?= /usr/bin/cut
+AWK?= /usr/bin/awk
+GREP?= /usr/bin/grep
+MOUNT?= /sbin/mount
.include <bsd.port.pre.mk>
+PROCFS!= ${MOUNT} | ${GREP} ^procfs | ${AWK} '{print $1}'
INSTALLATION_BASEDIR= OpenOffice.org1.0
DIST_SUBDIR= openoffice
DICT_DIR= ${PREFIX}/${INSTALLATION_BASEDIR}/share/dict/ooo/
@@ -153,6 +157,22 @@ CONFIGURE_ARGS+= --enable-gcc3
.endif
pre-fetch:
+ @${ECHO}
+ @${ECHO} "REQUIREMENTS:"
+.if ${PROCFS}
+ @${ECHO}
+ @${ECHO} Check if procfs is running: YES
+.else
+ @${ECHO} -----------------------------------------------------------
+ @${ECHO}
+ @${ECHO} OpenOffice setup still needs a running procfs, which may
+ @${ECHO} not be activated. Please read the procfs\(5\) manpage and
+ @${ECHO} ensure the the following line is in /etc/fstab:
+ @${ECHO}
+ @${ECHO} proc /proc procfs rw 0 0
+ @${ECHO}
+ @${ECHO} -----------------------------------------------------------
+.endif
.if !defined(USE_GCC) || !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "OPTIONS:"
diff --git a/editors/openoffice/pkg-message b/editors/openoffice/pkg-message
index 6395b787b3e0..4260551a1dcd 100644
--- a/editors/openoffice/pkg-message
+++ b/editors/openoffice/pkg-message
@@ -16,6 +16,14 @@ installation.
1.2 OO.org installed as package
+First check if procfs is running. OO.org setup does depend on
+procfs and does crash without it. This dependency will be
+removed in future, but at the moment it is needed.
+Please read the procfs(5) manpage and ensure the the following
+line is in /etc/fstab:
+
+proc /proc procfs rw 0 0
+
If you have just installed OO.org as package, there is no
"make install-user" option available. Instead you'll have
to run as the user you like to use OO.org: