aboutsummaryrefslogtreecommitdiffstats
path: root/editors/p5-Padre
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /editors/p5-Padre
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'editors/p5-Padre')
-rw-r--r--editors/p5-Padre/Makefile6
-rw-r--r--editors/p5-Padre/pkg-plist16
2 files changed, 10 insertions, 12 deletions
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index c68d90144364..f82f2eb17b87 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Padre
PORTVERSION= 1.00
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} ${MASTER_SITE_PERL_CPAN:S/$/:wxsc/}
MASTER_SITE_SUBDIR= ${PORTNAME}/:DEFAULT Wx/:wxsc
@@ -110,7 +110,7 @@ post-patch:
s|-lgtk-x11-2.0.*-lpangoft2-1.0|-lm| ; \
/-lgobject-2.0/d ; \
/-lglib-2.0/d ; \
- s|\\$$ORIGIN|${SITE_PERL}/${PERL_ARCH}/auto/Wx/Scintilla|' \
+ s|\\$$ORIGIN|${SITE_ARCH}/auto/Wx/Scintilla|' \
${WRKDIR}/${WXSC_DISTNAME}/inc/Module/Build/Scintilla/GTK.pm
pre-configure:
@@ -126,7 +126,7 @@ pre-install:
${PERL} Build install)
post-install:
- @(cd ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Wx/Scintilla && \
+ @(cd ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Wx/Scintilla && \
${STRIP_CMD} libwx_gtk2u_scintilla.so)
.include <bsd.port.post.mk>
diff --git a/editors/p5-Padre/pkg-plist b/editors/p5-Padre/pkg-plist
index 14929f85923a..d6c101aeeb46 100644
--- a/editors/p5-Padre/pkg-plist
+++ b/editors/p5-Padre/pkg-plist
@@ -579,12 +579,10 @@ bin/padre
%%SITE_PERL%%/auto/share/dist/Padre/themes/solarized_dark.txt
%%SITE_PERL%%/auto/share/dist/Padre/themes/solarized_light.txt
%%SITE_PERL%%/auto/share/dist/Padre/themes/ultraedit.txt
-%%SITE_PERL%%/%%PERL_ARCH%%/Wx/Scintilla.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Wx/Scintilla/Constant.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Wx/Scintilla/Manual.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/Wx/Scintilla/TextCtrl.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Wx/Scintilla/TextEvent.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Padre/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Wx/Scintilla/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Wx/Scintilla/Scintilla.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Wx/Scintilla/libwx_gtk2u_scintilla.so
+%%SITE_ARCH%%/Wx/Scintilla.pm
+%%SITE_ARCH%%/Wx/Scintilla/Constant.pm
+%%SITE_ARCH%%/Wx/Scintilla/Manual.pod
+%%SITE_ARCH%%/Wx/Scintilla/TextCtrl.pm
+%%SITE_ARCH%%/Wx/Scintilla/TextEvent.pm
+%%SITE_ARCH%%/auto/Wx/Scintilla/Scintilla.so
+%%SITE_ARCH%%/auto/Wx/Scintilla/libwx_gtk2u_scintilla.so