aboutsummaryrefslogtreecommitdiffstats
path: root/editors/p5-Padre
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
commitbdc7b8de9b4a00d6f78b8a20e6e92ad630e44558 (patch)
tree0af98c25fc0d67ccc871639ecd10e8476cfd8de7 /editors/p5-Padre
parenta72ed0005b1dc840337c91df5cde89b1015c75f8 (diff)
downloadfreebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.gz
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.zst
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.zip
- Remove ports that only work with < perl 5.12 (devel/p5-B-Size, devel/p5-Devel-Arena)
- Remove conditionals for PERL_LEVEL < 501200 - Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk - Other minor cleanups RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS} PR: ports/165605 Submitted by: pgollucci (myself) Approved by: portmgr (linimon) Exp Run by: linimon Tested by: make index
Diffstat (limited to 'editors/p5-Padre')
-rw-r--r--editors/p5-Padre/Makefile22
1 files changed, 1 insertions, 21 deletions
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index f795482bbf9d..a0002be2721e 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -79,7 +79,7 @@ WX_COMPS= wx contrib
WX_UNICODE= yes
USE_DISPLAY= yes
PERL_CONFIGURE= yes
-USE_PERL5= 5.8.5+
+USE_PERL5= yes
USE_GETTEXT= yes
MAKE_JOBS_UNSAFE= yes
@@ -94,26 +94,6 @@ IGNORE= needs a threaded Perl, build with WITH_THREADS=yes flag and try again
IGNORE= needs an existing installation of Perl built with WITH_THREADS=yes
.endif
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Pod-Simple>=3.07:${PORTSDIR}/textproc/p5-Pod-Simple
-.endif
-
-.if ${PERL_LEVEL} >= 501000 && ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Encode>=2.26:${PORTSDIR}/converters/p5-Encode \
- p5-Thread-Queue>=2.11:${PORTSDIR}/devel/p5-Thread-Queue \
- p5-threads>=1.71:${PORTSDIR}/devel/p5-threads \
- p5-threads-shared>=1.26:${PORTSDIR}/devel/p5-threads-shared
-RUN_DEPENDS+= p5-Encode>=2.26:${PORTSDIR}/converters/p5-Encode \
- p5-Thread-Queue>=2.11:${PORTSDIR}/devel/p5-Thread-Queue \
- p5-threads>=1.71:${PORTSDIR}/devel/p5-threads \
- p5-threads-shared>=1.26:${PORTSDIR}/devel/p5-threads-shared
-.endif
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-ExtUtils-Manifest>=1.56:${PORTSDIR}/devel/p5-ExtUtils-Manifest
-RUN_DEPENDS+= p5-ExtUtils-Manifest>=1.56:${PORTSDIR}/devel/p5-ExtUtils-Manifest
-.endif
-
MAN3= Padre.3 \
Padre::Action.3 \
Padre::Action::Debug.3 \