aboutsummaryrefslogtreecommitdiffstats
path: root/editors/texmaker
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /editors/texmaker
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'editors/texmaker')
-rw-r--r--editors/texmaker/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 35967e8969a6..d7d3b32d210e 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -31,9 +31,11 @@ OPTIONS_SINGLE_TOOLKIT= QT4 QT5
OPTIONS_DEFAULT= QT5
TOOLKIT_DESC= Qt toolkit
-QT4_USE= ${_USE_QT4:S/^/QT4=/}
+QT4_USES= qt:4
+QT4_USE= ${_USE_QT4:S/^/QT=/}
QT4_LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-QT5_USE= ${_USE_QT5:S/^/QT5=/}
+QT5_USES= qt:5
+QT5_USE= ${_USE_QT5:S/^/QT=/}
QT5_LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5
.include <bsd.port.mk>