aboutsummaryrefslogtreecommitdiffstats
path: root/editors/the
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-01-21 02:59:18 +0800
committerpi <pi@FreeBSD.org>2016-01-21 02:59:18 +0800
commit77b08e6ee7af89b47700c71a92ef0fa0f0241321 (patch)
treef734452f70e361dcd004a6ffedc80e53d7decc59 /editors/the
parent4b8c8fb437c84b774c798648d8e389ae7b936ba3 (diff)
downloadfreebsd-ports-gnome-77b08e6ee7af89b47700c71a92ef0fa0f0241321.tar.gz
freebsd-ports-gnome-77b08e6ee7af89b47700c71a92ef0fa0f0241321.tar.zst
freebsd-ports-gnome-77b08e6ee7af89b47700c71a92ef0fa0f0241321.zip
New port: editors/the
In fact, this is a reanimation with a newer version. THE is a text editor that uses both command line commands and key bindings to operate. It is intended to be similar to the VM/CMS System Product Editor, XEDIT and to Mansfield Software's, KEDIT. WWW: http://hessling-editor.sourceforge.net/ PR: 201187 Submitted by: Richard Narron <comet.berkeley@gmail.com>
Diffstat (limited to 'editors/the')
-rw-r--r--editors/the/Makefile77
-rw-r--r--editors/the/distinfo2
-rw-r--r--editors/the/pkg-descr5
-rw-r--r--editors/the/pkg-plist70
4 files changed, 154 insertions, 0 deletions
diff --git a/editors/the/Makefile b/editors/the/Makefile
new file mode 100644
index 000000000000..fbc9b40f09d0
--- /dev/null
+++ b/editors/the/Makefile
@@ -0,0 +1,77 @@
+# Created by: giffunip@asme.org
+# $FreeBSD$
+
+PORTNAME= the
+PORTVERSION= 3.3.r4
+CATEGORIES= editors
+MASTER_SITES= http://downloads.sourceforge.net/hessling-editor/
+DISTNAME= THE-${PORTVERSION:S/.r/RC/}
+
+MAINTAINER= comet.berkeley@gmail.com
+COMMENT= THE, The Hessling Editor, is like the vm/cms xedit editor
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ncurses \
+ --with-rexxincdir=${LOCALBASE}/include \
+ --with-rexxlibdir=${LOCALBASE}/lib
+ALL_TARGET= all html
+
+OPTIONS_DEFINE= XAW3D XCURSES REXX_IMC
+XAW3D_DESC= Enable Xaw3D
+XCURSES_DESC= Build XCurses (X11) version
+REXX_REGINA_DESC= Enable Rexx interpreter
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not configure on powerpc
+.endif
+
+.if ${PORT_OPTIONS:MXAW3D}
+CONFIGURE_ARGS+=--with-xaw3d
+LIB_DEPENDS+= libxaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
+.endif
+
+.if ${PORT_OPTIONS:MXCURSES}
+CONFIGURE_ARGS+=--with-xcurses \
+ --with-cursesincdir=${LOCALBASE}/include \
+ --with-curseslibdir=${LOCALBASE}/lib
+BUILD_DEPENDS+= pdcurses:${PORTSDIR}/devel/pdcurses
+LIB_DEPENDS+= libxcurses.so:${PORTSDIR}/devel/pdcurses
+PLIST_SUB= XCURSES="" NCURSES="@comment "
+.else
+PLIST_SUB= XCURSES="@comment " NCURSES=""
+.endif
+
+.if ${PORT_OPTIONS:MREXX_IMC}
+BUILD_DEPENDS+= rexx:${PORTSDIR}/lang/rexx-imc
+RUN_DEPENDS+= rexx:${PORTSDIR}/lang/rexx-imc
+CONFIGURE_ARGS+= --with-rexx=rexximc
+.else
+BUILD_DEPENDS+= regina:${PORTSDIR}/lang/rexx-regina
+RUN_DEPENDS+= regina:${PORTSDIR}/lang/rexx-regina
+CONFIGURE_ARGS+= --with-rexx=regina
+.endif
+
+post-extract:
+ ${REINPLACE_CMD} -e 's|(datadir)/THE|(datadir)/the|g' \
+ -e 's|/share/THE|/share/the|g' ${WRKSRC}/Makefile.in
+
+pre-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/the64.gif ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/the64.png ${STAGEDIR}${DOCSDIR}
+
+post-install:
+.if ${PORT_OPTIONS:MXCURSES}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xthe
+ ${LN} -sf xthe ${STAGEDIR}${PREFIX}/bin/the
+.else
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/nthe
+ ${LN} -sf nthe ${STAGEDIR}${PREFIX}/bin/the
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/editors/the/distinfo b/editors/the/distinfo
new file mode 100644
index 000000000000..5b95dfdc18cd
--- /dev/null
+++ b/editors/the/distinfo
@@ -0,0 +1,2 @@
+SHA256 (THE-3.3RC4.tar.gz) = 8781cd1ae2616a4d424e4847f881709b140cf7da209fe46828170d90a63bd1f0
+SIZE (THE-3.3RC4.tar.gz) = 1156675
diff --git a/editors/the/pkg-descr b/editors/the/pkg-descr
new file mode 100644
index 000000000000..aae48979c08c
--- /dev/null
+++ b/editors/the/pkg-descr
@@ -0,0 +1,5 @@
+THE is a text editor that uses both command line commands and key bindings
+to operate. It is intended to be similar to the VM/CMS System Product
+Editor, XEDIT and to Mansfield Software's, KEDIT.
+
+WWW: http://hessling-editor.sourceforge.net/
diff --git a/editors/the/pkg-plist b/editors/the/pkg-plist
new file mode 100644
index 000000000000..3109b56ec9f4
--- /dev/null
+++ b/editors/the/pkg-plist
@@ -0,0 +1,70 @@
+%%NCURSES%%bin/nthe
+bin/the
+%%XCURSES%%bin/xthe
+man/man1/the.1.gz
+@dir %%DATADIR%%
+%%DATADIR%%/THE_Help.txt
+%%DATADIR%%/abf.tld
+%%DATADIR%%/append.the
+%%DATADIR%%/build.the
+%%DATADIR%%/c.tld
+%%DATADIR%%/cdiff.tld
+%%DATADIR%%/cobol.tld
+%%DATADIR%%/codecomp.the
+%%DATADIR%%/comm.the
+%%DATADIR%%/compile.the
+%%DATADIR%%/complete.the
+%%DATADIR%%/config.the
+%%DATADIR%%/csh.tld
+%%DATADIR%%/cua.the
+%%DATADIR%%/demo.the
+%%DATADIR%%/diff.tld
+%%DATADIR%%/dir.tld
+%%DATADIR%%/fortran.tld
+%%DATADIR%%/html.tld
+%%DATADIR%%/java.tld
+%%DATADIR%%/js.tld
+%%DATADIR%%/l.the
+%%DATADIR%%/m4.tld
+%%DATADIR%%/make.tld
+%%DATADIR%%/match.the
+%%DATADIR%%/nl.the
+%%DATADIR%%/nsi.tld
+%%DATADIR%%/objc.tld
+%%DATADIR%%/opl.tld
+%%DATADIR%%/plsql.tld
+%%DATADIR%%/rexx.syntax
+%%DATADIR%%/rexx.tld
+%%DATADIR%%/rexxdw.syntax
+%%DATADIR%%/rexxeec.syntax
+%%DATADIR%%/rexxutil.syntax
+%%DATADIR%%/rm.the
+%%DATADIR%%/sh.tld
+%%DATADIR%%/spec.tld
+%%DATADIR%%/spell.the
+%%DATADIR%%/syntax.the
+%%DATADIR%%/tags.the
+%%DATADIR%%/total.the
+%%DATADIR%%/udiff.tld
+%%DATADIR%%/uncomm.the
+%%DATADIR%%/words.the
+@dir %%PORTDOCS%%%%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/app1.html
+%%PORTDOCS%%%%DOCSDIR%%/app2.html
+%%PORTDOCS%%%%DOCSDIR%%/app3.html
+%%PORTDOCS%%%%DOCSDIR%%/app4.html
+%%PORTDOCS%%%%DOCSDIR%%/app5.html
+%%PORTDOCS%%%%DOCSDIR%%/app6.html
+%%PORTDOCS%%%%DOCSDIR%%/app7.html
+%%PORTDOCS%%%%DOCSDIR%%/comm.html
+%%PORTDOCS%%%%DOCSDIR%%/commset.html
+%%PORTDOCS%%%%DOCSDIR%%/commsos.html
+%%PORTDOCS%%%%DOCSDIR%%/fdl.html
+%%PORTDOCS%%%%DOCSDIR%%/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/history.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/query.html
+%%PORTDOCS%%%%DOCSDIR%%/quickref.html
+%%PORTDOCS%%%%DOCSDIR%%/the64.gif
+%%PORTDOCS%%%%DOCSDIR%%/the64.png