aboutsummaryrefslogtreecommitdiffstats
path: root/editors/tweak
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2009-02-18 03:51:46 +0800
committered <ed@FreeBSD.org>2009-02-18 03:51:46 +0800
commit7bd1d8971f0f44e4646d5c52b07e74b95baeb30f (patch)
tree6bf97a8827f3612302c490458bc970e8b2ef9ed1 /editors/tweak
parent4a022b4c9c0860e617b799d59c1eb9c50a6053f1 (diff)
downloadfreebsd-ports-gnome-7bd1d8971f0f44e4646d5c52b07e74b95baeb30f.tar.gz
freebsd-ports-gnome-7bd1d8971f0f44e4646d5c52b07e74b95baeb30f.tar.zst
freebsd-ports-gnome-7bd1d8971f0f44e4646d5c52b07e74b95baeb30f.zip
Make tweak honour compiler flags CC, CFLAGS, LDFLAGS, etc.
The Makefile that gets shipped with tweak overrides the default values of the well known make variables. Because a diff to sanitize the Makefile would be bigger than replacing it, add a BSD Makefile to the files/ directory. Also remove the unneeded commented DISTNAME line from the Makefile. Approved by: Jille Timmermans <jille quis cx> (port maintainer)
Diffstat (limited to 'editors/tweak')
-rw-r--r--editors/tweak/Makefile6
-rw-r--r--editors/tweak/files/Makefile.in7
2 files changed, 11 insertions, 2 deletions
diff --git a/editors/tweak/Makefile b/editors/tweak/Makefile
index 1c37051c9625..a5deb8368189 100644
--- a/editors/tweak/Makefile
+++ b/editors/tweak/Makefile
@@ -7,13 +7,15 @@ PORTNAME= tweak
PORTVERSION= 3.01
CATEGORIES= editors
MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/${PORTNAME}/
-#DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= jille@quis.cx
COMMENT= An efficient hex editor
-USE_GMAKE= yes
MAN1= tweak.1
+MANCOMPRESSED= yes
PLIST_FILES= bin/tweak
+MAKEFILE= ${FILESDIR}/Makefile.in
+MAKE_ENV+= BINDIR="${LOCALBASE}/bin" MANDIR="${PREFIX}/man/man"
+
.include <bsd.port.mk>
diff --git a/editors/tweak/files/Makefile.in b/editors/tweak/files/Makefile.in
new file mode 100644
index 000000000000..1f82158c7aa4
--- /dev/null
+++ b/editors/tweak/files/Makefile.in
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+PROG= tweak
+SRCS= actions.c btree.c buffer.c curses.c keytab.c main.c rcfile.c search.c
+LDADD= -lncurses
+
+.include <bsd.prog.mk>