aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim/files
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-05 01:28:09 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-05 01:28:09 +0800
commit4930b610602e519f40f8b1de64f96fbbb8cc7c40 (patch)
tree69d7f2f5ee57f3dadd2ff4d308d76b584a68184e /editors/vim/files
parent97ffd4220fab90f983e60dfc84272ae6aea510c4 (diff)
downloadfreebsd-ports-gnome-4930b610602e519f40f8b1de64f96fbbb8cc7c40.tar.gz
freebsd-ports-gnome-4930b610602e519f40f8b1de64f96fbbb8cc7c40.tar.zst
freebsd-ports-gnome-4930b610602e519f40f8b1de64f96fbbb8cc7c40.zip
Move the vimrc into ETCDIR to user may have a look at it.
Now install a minimalistic vimrc without all the controversial options (I hope) Define a template for port Makefiles to vim automatically creates it in case of opening a new one
Diffstat (limited to 'editors/vim/files')
-rw-r--r--editors/vim/files/vimrc23
1 files changed, 23 insertions, 0 deletions
diff --git a/editors/vim/files/vimrc b/editors/vim/files/vimrc
new file mode 100644
index 000000000000..21df2d3f1b11
--- /dev/null
+++ b/editors/vim/files/vimrc
@@ -0,0 +1,23 @@
+if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
+ set fileencodings=ucs-bom,utf-8,latin1
+endif
+
+set nocompatible
+set bs=indent,eol,start
+set history=50
+set ruler
+
+if &t_Co > 2 || has("gui_running")
+ syntax on
+ set hlsearch
+endif
+
+if has("autocmd")
+ augroup freebsd
+ autocmd!
+ if $PORTSDIR != ""
+ autocmd BufNewFile $PORTSDIR/*/*/Makefile 0r $PORTSDIR/Templates/Makefile
+ else
+ autocmd BufNewFile /usr/ports/*/*/Makefile 0r /usr/ports/Templates/Makefile
+ endif
+endif