aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim5/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2001-02-15 20:47:40 +0800
committerobrien <obrien@FreeBSD.org>2001-02-15 20:47:40 +0800
commit37b12e3bc292f3399706282b22dcb79ca08b5c32 (patch)
tree72cd15ce29c5eedf3d2710eb2b7cdd5130dc29d3 /editors/vim5/Makefile
parenta4e478bf5cc0a13467f23f9b452635b7ac99fdc3 (diff)
downloadfreebsd-ports-gnome-37b12e3bc292f3399706282b22dcb79ca08b5c32.tar.gz
freebsd-ports-gnome-37b12e3bc292f3399706282b22dcb79ca08b5c32.tar.zst
freebsd-ports-gnome-37b12e3bc292f3399706282b22dcb79ca08b5c32.zip
Add a "NO_GUI" knob for those that want full features w/o dependence on X.
Submitted by: Peter Pentchev <roam@orbitel.bg> I'm torn between having so many knobs and having the 'vim-lite' be the Right Thing for sysadmins on Xless router boxes. I'm open to opinions on if 'vim-lite' should only mean no X, or it should also mean no interpreters
Diffstat (limited to 'editors/vim5/Makefile')
-rw-r--r--editors/vim5/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index f80528cb4118..247261cf566a 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -57,6 +57,7 @@ LIBS=-lxpg4
MAKE_ARGS+= CONF_OPT_MAX="--enable-max-features"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
+.if !defined(NO_GUI)
.if defined(WITH_ATHENA)
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena" ${I18N}
#MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=yes" ${I18N}
@@ -67,6 +68,9 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE}" ${I18N}
USE_MOTIF= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\"" MOTIFHOME=${X11BASE} ${I18N}
.endif
+.else # NO_GUI
+MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
+.endif # NO_GUI
.if defined(PACKAGE_BUILDING)
MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp --enable-pythoninterp --enable-tclinterp --enable-cscope"