aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2018-01-09 03:44:13 +0800
committeradamw <adamw@FreeBSD.org>2018-01-09 03:44:13 +0800
commit184d3321d9f6f2987c7cc838949b7801e4e64a99 (patch)
tree7e29ca1cd3d83b813e8da78483a5db651348c0d9 /editors/vim
parentca2931d223ea88326c8590a4dd54d929f1feb70f (diff)
downloadfreebsd-ports-gnome-184d3321d9f6f2987c7cc838949b7801e4e64a99.tar.gz
freebsd-ports-gnome-184d3321d9f6f2987c7cc838949b7801e4e64a99.tar.zst
freebsd-ports-gnome-184d3321d9f6f2987c7cc838949b7801e4e64a99.zip
Add editors/vim-tiny.
By popular request, this is a slave port that installs only the vim binary. It has no dependencies, produces a 1 MB package with a 3 MB installed footprint, and is unable to do anything except edit files. It contains no help files, no runtime files, no syntax highlighting, no filetype-specific indenting, non-US keymaps, macros, or spell-checking. vim-tiny is designed for minimal installs, and is the wrong choice for most users.
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 36bb1da1702b..c50c1fb1641e 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -14,7 +14,7 @@ LICENSE_NAME= VIM License
LICENSE_FILE= ${WRKSRC}/runtime/doc/uganda.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS_INSTALL?= vim-lite-[0-9]*
+CONFLICTS_INSTALL?= vim-lite vim-tiny
USES= cpe iconv ncurses pkgconfig shebangfix
USE_GITHUB= yes
@@ -30,7 +30,7 @@ CPE_VERSION= ${PORTVERSION:R}
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
PLIST_SUB= VIM_VER=${VIM_VER}
-PORTDATA= ${VIM_VER}
+PORTDATA?= ${VIM_VER}
PORTSCOUT= ignore:1
REINPLACE_ARGS= -i ''
SHEBANG_FILES= runtime/tools/demoserver.py runtime/tools/efm_perl.pl
@@ -52,6 +52,11 @@ OPTIONS_SLAVE= CONSOLE
OPTIONS_EXCLUDE:= ${OPTIONS_DEFINE:NDEFAULT_VIMRC} \
${OPTIONS_SINGLE_UI:NCONSOLE} \
${OPTIONS_GROUP_LANGBIND}
+.elif defined(TINY)
+OPTIONS_SLAVE= CONSOLE
+OPTIONS_EXCLUDE:= ${OPTIONS_DEFINE} \
+ ${OPTIONS_SINGLE_UI:NCONSOLE} \
+ ${OPTIONS_GROUP_LANGBIND}
.endif
DEFAULT_VIMRC_DESC= Install bundled vimrc as default setting
@@ -156,6 +161,7 @@ post-configure:
# Needed when devel/libsysinfo is installed:
@${REINPLACE_CMD} -e '/#define HAVE_SYSINFO 1/ d' ${WRKSRC}/src/auto/config.h
+.if !defined(TINY)
post-install:
@${RM} ${STAGEDIR}${PREFIX}/bin/ex
@${RM} ${STAGEDIR}${PREFIX}/bin/view
@@ -187,5 +193,6 @@ post-install-NLS-off:
@${MKDIR} ${STAGEDIR}${DATADIR}/${VIM_VER}/lang
@${MKDIR} ${STAGEDIR}${DATADIR}/${VIM_VER}/keymap
${INSTALL_DATA} ${WRKSRC}/runtime/keymap/* ${STAGEDIR}${DATADIR}/${VIM_VER}/keymap
+.endif #!defined(TINY)
.include <bsd.port.mk>