aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-05 16:23:44 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-05 16:23:44 +0800
commit2088f0950096ac6ce93100c3d2b4a8669cf97f57 (patch)
treee929e8ac0a3df21219cbcb55911d56834940dc94 /editors/vim
parentcfb3d75b35080ad75b44f5b938b1a1b834a7f607 (diff)
downloadfreebsd-ports-gnome-2088f0950096ac6ce93100c3d2b4a8669cf97f57.tar.gz
freebsd-ports-gnome-2088f0950096ac6ce93100c3d2b4a8669cf97f57.tar.zst
freebsd-ports-gnome-2088f0950096ac6ce93100c3d2b4a8669cf97f57.zip
Fix conversion to optionsng breaking multibyte support
Reported by: Sergey V. Dyatko via irc Tested by: Sergey V. Dyatko via irc Approved by: portmgr (implicit)
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 3675360634b2..1273cc819b84 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -112,11 +112,12 @@ WANT_GNOME= yes
.if defined(LITE)
PKGNAMESUFFIX= -lite
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
+CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable-tclinterp --disable-rubyinterp --disable-luainterp"
.else # !LITE
MAKE_ARGS+= CONF_OPT_FEAT="--with-features=big"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
+CONF_OPT_GUI="--enable-gui=no --without-x"
.endif
.if ${PORT_OPTIONS:MCSCOPE}
@@ -131,7 +132,6 @@ CTAGS_CMD= exctags -R .
CTAGS_CMD= ${FIND} . -type f \\|${XARGS} ctags
.endif
-CONF_OPT_GUI="--enable-gui=no --without-x"
.if ${PORT_OPTIONS:MX11}
CONF_OPT_GUI="--enable-gui=no --with-x"