aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-03-29 00:12:11 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-03-29 00:12:11 +0800
commit567293b32a619b52cd90e24dbb41cf5e877514b6 (patch)
treeeea490fc6a9686cc666eb934a6cbfd281e64b39b /editors/vim
parent4a4c19aaebde1f8803df0dcef13609466ce0dba4 (diff)
downloadfreebsd-ports-gnome-567293b32a619b52cd90e24dbb41cf5e877514b6.tar.gz
freebsd-ports-gnome-567293b32a619b52cd90e24dbb41cf5e877514b6.tar.zst
freebsd-ports-gnome-567293b32a619b52cd90e24dbb41cf5e877514b6.zip
- Add "let: g:is_posix = 1" to default vimrc
- Bump PORTREVISION for package change PR: 198728 Submitted by: <yuri@rawbw.com>
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile2
-rw-r--r--editors/vim/files/vimrc1
2 files changed, 2 insertions, 1 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index fb2cba242c40..1f288bf5f32b 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vim
PORTVERSION= 7.4.${PATCHLEVEL}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= editors
MASTER_SITES= VIM:source \
${MASTER_SITE_VIM:S|unix|patches/${PORTVERSION:R}|}:patch \
diff --git a/editors/vim/files/vimrc b/editors/vim/files/vimrc
index 21df2d3f1b11..cd041eb34648 100644
--- a/editors/vim/files/vimrc
+++ b/editors/vim/files/vimrc
@@ -2,6 +2,7 @@ if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
set fileencodings=ucs-bom,utf-8,latin1
endif
+let g:is_posix = 1
set nocompatible
set bs=indent,eol,start
set history=50