aboutsummaryrefslogtreecommitdiffstats
path: root/editors/vim
diff options
context:
space:
mode:
authoralfred <alfred@FreeBSD.org>2014-11-17 06:55:10 +0800
committeralfred <alfred@FreeBSD.org>2014-11-17 06:55:10 +0800
commit80c3a61bef4882d8d70b9d5fd07c1d3563168c8e (patch)
tree2ec141dc587ce1939dc6719f7255b9dc618787fd /editors/vim
parent8559606aae966a487ea3b565bc3e266c04b7e3ce (diff)
downloadfreebsd-ports-gnome-80c3a61bef4882d8d70b9d5fd07c1d3563168c8e.tar.gz
freebsd-ports-gnome-80c3a61bef4882d8d70b9d5fd07c1d3563168c8e.tar.zst
freebsd-ports-gnome-80c3a61bef4882d8d70b9d5fd07c1d3563168c8e.zip
Use vimrc from distribution.
Suggested by: many.
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile8
-rw-r--r--editors/vim/files/vimrc49
-rw-r--r--editors/vim/pkg-plist2
3 files changed, 8 insertions, 51 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index a409c2a9dad0..a0307706a911 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -58,7 +58,7 @@ INSTALL_WRKSRC= ${WRKDIR}/${VIM_VER}/src
WRKSRC= ${WRKDIR}/${VIM_VER}
PLIST_SUB= VIM_VER=${VIM_VER}
-PORTDATA= *
+PORTDATA= ${VIM_VER}
VIM_VER= ${PORTNAME}${PORTVERSION:R:S/.//g}
@@ -126,6 +126,9 @@ IGNORE= this port has new UI option (CONSOLE) for users who do not need GUI sup
.if ${PORT_OPTIONS:MDEFAULT_VIMRC}
DEFAULT_VIMRC_LOCATION=${PREFIX}/share/vim
+PLIST_SUB+= DEFAULT_VIMRC="@sample "
+.else
+PLIST_SUB+= DEFAULT_VIMRC="@comment "
.endif
.if ${PORT_OPTIONS:MCONSOLE} || ${PORT_OPTIONS:MX11}
@@ -191,7 +194,8 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/vietnamese_viscii.vim ${STAGEDIR}${DATADIR}/${VIM_VER}/keymap/
${TOUCH} ${STAGEDIR}${DATADIR}/${VIM_VER}/lang/.keepme
.if ${PORT_OPTIONS:MDEFAULT_VIMRC}
- ${INSTALL_DATA} ${FILESDIR}/vimrc ${STAGEDIR}${DEFAULT_VIMRC_LOCATION}/vimrc
+ ${INSTALL_DATA} ${WRKSRC}/runtime/vimrc_example.vim ${STAGEDIR}${DEFAULT_VIMRC_LOCATION}/vimrc
+ ${INSTALL_DATA} ${WRKSRC}/runtime/gvimrc_example.vim ${STAGEDIR}${DEFAULT_VIMRC_LOCATION}/gvimrc
.endif
.include <bsd.port.post.mk>
diff --git a/editors/vim/files/vimrc b/editors/vim/files/vimrc
deleted file mode 100644
index 64321a3d2e50..000000000000
--- a/editors/vim/files/vimrc
+++ /dev/null
@@ -1,49 +0,0 @@
-" Uncomment the next line to make Vim more Vi-compatible
-" From ubuntu's vimrc, slightly modified for FreeBSD ports.
-"set compatible
-
-" Vim5 and later versions support syntax highlighting. Uncommenting the next
-" line enables syntax highlighting by default.
-if has("syntax")
- syntax on
-endif
-
-" This is the problem most of the time.
-set nocompatible
-
-" Sensible backspace setting, seems to work on most terminals.
-set backspace=2
-
-" If using a dark background within the editing area and syntax highlighting
-" turn on this option as well
-"set background=dark
-
-" Uncomment the following to have Vim jump to the last position when
-" reopening a file
-"if has("autocmd")
-" au BufReadPost * if line("'\"") > 1 && line("'\"") <= line("$") | exe "normal! g'\"" | endif
-"endif
-
-" Uncomment the following to have Vim load indentation rules and plugins
-" according to the detected filetype.
-"if has("autocmd")
-" filetype plugin indent on
-"endif
-
-" The following are commented out as they cause vim to behave a lot
-" differently from regular Vi. They are highly recommended though.
-"set showcmd " Show (partial) command in status line.
-"set showmatch " Show matching brackets.
-"set ignorecase " Do case insensitive matching
-"set smartcase " Do smart case matching
-"set incsearch " Incremental search
-"set autowrite " Automatically save before commands like :next and :make
-"set hidden " Hide buffers when they are abandoned
-"set mouse=a " Enable mouse usage (all modes)
-
-" Source a global configuration file if available
-if filereadable($VIMRUNTIME . "/vimrc")
- source $VIMRUNTIME . "/vimrc"
-endif
-
-
diff --git a/editors/vim/pkg-plist b/editors/vim/pkg-plist
index 203cc5d5c969..8050bd172a48 100644
--- a/editors/vim/pkg-plist
+++ b/editors/vim/pkg-plist
@@ -184,3 +184,5 @@ man/man1/xxd.1.gz
%%NON_LITE%%%%NLS%%man/ru.UTF-8/man1/vimdiff.1.gz
%%NON_LITE%%%%NLS%%man/ru.UTF-8/man1/vimtutor.1.gz
%%NON_LITE%%%%NLS%%man/ru.UTF-8/man1/xxd.1.gz
+%%DEFAULT_VIMRC%%share/vim/vimrc
+%%DEFAULT_VIMRC%%share/vim/gvimrc