aboutsummaryrefslogtreecommitdiffstats
path: root/editors/wily/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-11-17 19:53:06 +0800
committertg <tg@FreeBSD.org>1997-11-17 19:53:06 +0800
commit3ecc3fa8183bca32d18c51c0f5080f854a9c7f0d (patch)
treef81e713b5bac2a01e0b71cff105e5e923cd9f830 /editors/wily/Makefile
parentc55698b1f59b1dca84e7cedb589fbc10dcf3ca3f (diff)
downloadfreebsd-ports-gnome-3ecc3fa8183bca32d18c51c0f5080f854a9c7f0d.tar.gz
freebsd-ports-gnome-3ecc3fa8183bca32d18c51c0f5080f854a9c7f0d.tar.zst
freebsd-ports-gnome-3ecc3fa8183bca32d18c51c0f5080f854a9c7f0d.zip
Import wily port. wily is a clone of the plan9 editor acme.
PR: 4624 Submitted by: A Joseph Koshy <koshy@india.hp.com>
Diffstat (limited to 'editors/wily/Makefile')
-rw-r--r--editors/wily/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/editors/wily/Makefile b/editors/wily/Makefile
new file mode 100644
index 000000000000..87e2a3a69430
--- /dev/null
+++ b/editors/wily/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: wily
+# Version required: 0.13.36
+# Date created: 23 September 1997
+# Whom: koshy
+#
+# $Id$
+#
+
+DISTNAME= wily-0.13.36
+CATEGORIES= plan9 editors
+MASTER_SITES= ftp://ftp.northsea.com/pub/plan9_unix/wily/wily/src/ \
+ ftp://ftp.cs.york.ac.uk/pub/mhw/wily/src/ \
+ ftp://ftp.cs.su.oz.au/gary/wily/src/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= koshy@india.hp.com
+
+USE_X11= YES
+GNU_CONFIGURE= YES
+
+WILYDOCDIR= ${PREFIX}/share/doc/wily
+WILYDOCFILES= index.html intro.html download.html credits.html FAQ.txt \
+ onepage.html user.html idioms.html C.html python.html \
+ perl.txt hack.html changes.txt AcmeVsWily.html Tcl.html \
+ pythonpaper.html winmanager.html
+
+# The default Wily makefile does not install any documentation. Rectify.
+post-install:
+ strip ${PREFIX}/bin/wily
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${WILYDOCDIR}
+ set -e; for f in ${WILYDOCFILES}; do \
+ ${INSTALL_DATA} ${WRKSRC}/Doc/$${f} ${WILYDOCDIR}/$${f}; \
+ done
+.endif
+
+.include <bsd.port.mk>