aboutsummaryrefslogtreecommitdiffstats
path: root/editors/xemacs-devel-mule
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2010-09-16 02:35:24 +0800
committerade <ade@FreeBSD.org>2010-09-16 02:35:24 +0800
commit3ad75a4581c2f69fb2331ab72fee36ff8af166ba (patch)
treeb5ab9adb45e9a850892479ebc329ab2118d673c8 /editors/xemacs-devel-mule
parentf72275e68db56a5d187d3a748951a6347a5ace60 (diff)
downloadfreebsd-ports-gnome-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.tar.gz
freebsd-ports-gnome-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.tar.zst
freebsd-ports-gnome-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.zip
Autotools update. Read ports/UPDATING 20100915 for details.
Approved by: portmgr (for Mk/bsd.port.mk part) Tested by: Multiple -exp runs
Diffstat (limited to 'editors/xemacs-devel-mule')
-rw-r--r--editors/xemacs-devel-mule/Makefile7
-rw-r--r--editors/xemacs-devel-mule/files/patch-configure.ac38
2 files changed, 37 insertions, 8 deletions
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index 75e6d37250a0..d6233bf719f5 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xemacs-devel-mule
PORTVERSION= ${XEMACS_VER:S/-/./}
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
@@ -53,7 +53,7 @@ XEMACS_ARCH= ${MACHINE_ARCH}--freebsd
WRKSRC= ${WRKDIR}/xemacs-${XEMACS_VER:S/-b/./}
STRIP=
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
CONFIGURE_TARGET=${XEMACS_ARCH}
CONFIGURE_ARGS+= --enable-mule \
@@ -110,6 +110,9 @@ CONFIGURE_ARGS+=--disable-kkcc --disable-mc-alloc --disable-newgc
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
USE_XORG+= x11 xft xpm
CONFIGURE_ARGS+=--with-xft=all
+# XXX: needed until port updated to work nicely with autoconf >= 2.64
+# see files/patch-configure.ac for more details
+CFLAGS+= -I${LOCALBASE}/include/freetype2
.elif defined(WITH_GTK)
CONFIGURE_ARGS+=--with-gtk
WITH_XIM=
diff --git a/editors/xemacs-devel-mule/files/patch-configure.ac b/editors/xemacs-devel-mule/files/patch-configure.ac
index c61834620e46..a20f0c608c91 100644
--- a/editors/xemacs-devel-mule/files/patch-configure.ac
+++ b/editors/xemacs-devel-mule/files/patch-configure.ac
@@ -1,5 +1,5 @@
--- configure.ac.orig 2007-05-21 03:50:13.000000000 +0000
-+++ configure.ac 2008-08-04 13:51:25.000000000 +0000
++++ configure.ac 2010-06-14 13:42:26.000000000 +0000
@@ -389,5 +389,7 @@
dnl
+dnl m4_fst disappeared without a trace in autoconf 2.62
@@ -13,12 +13,38 @@
*-*-linux* ) opsys=linux ;;
+ *-*-freebsd* ) opsys=freebsd ;;
*-*-netbsd* ) opsys=netbsd ;;
-@@ -3496,3 +3499,3 @@
- for freetype_include_top in "/usr/X11R6/include/freetype2" \
+@@ -3487,26 +3490,7 @@
+
++ dnl XXX: autoconf > 2.64 AC_CHECK_HEADERS requires the headers to actually
++ dnl XXX: preprocess, and not just exist, so for now, we say 'yes'
++ dnl XXX: unconditionally if asked, and let it fall over elsewhere
+ if test "$with_xft_emacs" = "yes"; then
+- AC_MSG_CHECKING([for Xrender, fontconfig, and Xft])
+- xft_includes_found=no
+- AC_CHECK_HEADERS([freetype/config/ftheader.h],
+- [xft_includes_found=yes],
+- [
+- dnl #### How about /sw/include, and /opt/local/include?
+- dnl these directories need to be the parent of the freetype directory
+- for freetype_include_top in "/usr/X11R6/include/freetype2" \
- "/usr/include/freetype2"
-+ "$with_site_includes/freetype2"
- do
-@@ -5420,3 +5423,3 @@
+- do
+- if test -d $freetype_include_top; then
+- AC_MSG_CHECKING([in ${freetype_include_top}/freetype2])
+- dnl disable autoconf's fucking cache; why these fuckheads think it
+- dnl is better to be broken than to be slow, I don't know!
+- dnl #### there's gotta be a better-looking way to do this!!
+- unset "$as_ac_Header"
+- save_c_switch_site="$c_switch_site"
+- c_switch_site="$c_switch_site -I${freetype_include_top}"
+- AC_CHECK_HEADERS([freetype/config/ftheader.h],
+- [xft_includes_found=yes],
+- [c_switch_site=$save_c_switch_site])
+- fi
+- done])
++ xft_includes_found=yes
+ if test "$xft_includes_found" != "yes"; then
+@@ -5420,3 +5404,3 @@
AC_MSG_CHECKING(for Berkeley db.h)
- for header in "db/db.h" "db.h"; do
+ for header in "/usr/include/db.h" "db/db.h" "db.h"; do