aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-08-30 11:56:22 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-08-30 11:56:22 +0800
commit1244c041a05f03190ad70cb53677bdbd9657ed9c (patch)
treedb40a9170761885a2ced0cc8e4761a56647753cc /editors
parentd761069c3173652a2de56959dd007ad3d4c3d23b (diff)
downloadfreebsd-ports-gnome-1244c041a05f03190ad70cb53677bdbd9657ed9c.tar.gz
freebsd-ports-gnome-1244c041a05f03190ad70cb53677bdbd9657ed9c.tar.zst
freebsd-ports-gnome-1244c041a05f03190ad70cb53677bdbd9657ed9c.zip
- Convert to new options targer helper
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index e61b53a850fd..a91cb5870e2e 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -98,14 +98,6 @@ X11_MAKE_ARGS= CONF_OPT_GUI="--enable-gui=no --with-x" X_LIBS="$(X_LIBS) -lX11
X11_PLIST_SUB= GUI="@comment "
X11_USE= XORG=x11,xt
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXUBERANT_CTAGS}
-CTAGS_CMD= exctags -R .
-.else
-CTAGS_CMD= ${FIND} . -type f \\| ${XARGS} ctags
-.endif
-
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MPYTHON}
@@ -119,10 +111,15 @@ MAKE_ARGS+= CONF_OPT_PYTHON="--enable-python3interp --disable-pythoninterp"
post-patch:
@${REINPLACE_CMD} -e '/^install_normal: / s|install-icons|# &|; /cd $$(DEST_BIN); ln -s/d' ${WRKSRC}/src/Makefile
@${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|g' ${WRKSRC}/src/auto/configure
- @${FIND} ${WRKSRC}/runtime/ -name menu\*.vim -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's,ctags -R \.,${CTAGS_CMD},g'
@${ECHO_CMD} '#define SYS_VIMRC_FILE "'${ETCDIR}'/vimrc"' >> ${WRKSRC}/src/feature.h
@${ECHO_CMD} '#define SYS_GVIMRC_FILE "'${ETCDIR}'/gvimrc"' >> ${WRKSRC}/src/feature.h
+post-patch-EXUBERANT_CTAGS-off:
+ @${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|ctags -R \.|${FIND} . -type f \| ${XARGS} ctags|g'
+
+post-patch-EXUBERANT_CTAGS-on:
+ @${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|ctags -R \.|exctags -R .|g'
+
pre-configure:
@${CP} ${WRKSRC}/src/config.mk.dist ${WRKSRC}/src/auto/config.mk
@(cd ${WRKSRC}/src/ && ${MAKE_CMD} distclean)
@@ -130,9 +127,9 @@ pre-configure:
-e 's|\$$gtk_config_prefix/bin/gtk-config|\$${GTK_CONFIG}|g' \
-e 's|\$$gtk_config_exec_prefix/bin/gtk-config|\$${GTK_CONFIG}|g' \
-e 's|set dummy lua;|set dummy ${LUA_CMD};|g' ${WRKSRC}/src/auto/configure
-.if ${PORT_OPTIONS:MXTERM_SAVE}
+
+pre-configure-XTERM_SAVE-on:
@${REINPLACE_CMD} -e '/FEAT_XTERM_SAVE/ s|.*|#define FEAT_XTERM_SAVE|' ${WRKSRC}/src/feature.h
-.endif
post-configure:
@(cd ${WRKSRC}/src/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} scratch config)