aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2019-11-02 05:51:36 +0800
committertcberner <tcberner@FreeBSD.org>2019-11-02 05:51:36 +0800
commit140f6235406163f9588959c326febf4761143984 (patch)
treece13218697645e8981b36e7589f64b42e3049ce5 /editors
parent939092bd26576f964d08e13907318d14fa024e2a (diff)
downloadfreebsd-ports-gnome-140f6235406163f9588959c326febf4761143984.tar.gz
freebsd-ports-gnome-140f6235406163f9588959c326febf4761143984.tar.zst
freebsd-ports-gnome-140f6235406163f9588959c326febf4761143984.zip
graphics/poppler: update to 0.82.0
Release 0.82.0: core: * Fix not being able to open some files. Issue #832 * Fix crashes in malformed files * Fix memory leak on broken files * Minor performance improvements * Minor code improvements glib: * Add poppler_document_new_from_bytes * PopplerAttachment: Silence deprecation warnings for ctime/mtime build system: * pdf-inspector: Support builddir != srcdir * Install Cairo* headers if Cairo has been found Thanks to adridg@ for fixing all the fallout. Exp-run by: antoine PR: 241532 Approved by: gnome (kwm, implicit)
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile6
-rw-r--r--editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp26
-rw-r--r--editors/calligra/files/patch-sheets_plugins_calendar_CalendarToolWidget.cpp (renamed from editors/calligra/files/patch-gentoo-kf5-5.61-headers)10
-rw-r--r--editors/calligra/files/patch-stage_part_KPrPresentationTool.cpp (renamed from editors/calligra/files/patch-git_70be8c4)0
-rw-r--r--editors/kile/Makefile1
-rw-r--r--editors/libreoffice/Makefile1
-rw-r--r--editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.cxx35
-rw-r--r--editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.hxx39
-rw-r--r--editors/openoffice-devel/Makefile2
-rw-r--r--editors/texstudio/Makefile2
-rw-r--r--editors/texworks/Makefile2
11 files changed, 105 insertions, 19 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 701b7037368c..102b3b16cdfe 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -2,7 +2,7 @@
PORTNAME= calligra
DISTVERSION= 3.1.0
-PORTREVISION= 26
+PORTREVISION= 28
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -69,8 +69,4 @@ CMAKE_ARGS+= -DCMAKE_CXX_FLAGS="-DKDE_NO_DEBUG_OUTPUT"
PLIST_SUB+= SHLIB_VER=16.0.0
-post-patch:
- # Fix with poppler 0.73
- ${REINPLACE_CMD} -e 's|Guchar|unsigned char|g' \
- ${WRKSRC}/filters/karbon/pdf/SvgOutputDev.cpp
.include <bsd.port.mk>
diff --git a/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp b/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp
index 911bedf7e936..6cba91fffbb2 100644
--- a/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp
+++ b/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp
@@ -101,7 +101,7 @@
{
int render = state->getRender();
// check for invisible text -- this is used by Acrobat Capture
-@@ -402,7 +408,7 @@ void SvgOutputDev::drawString(GfxState * state, GooStr
+@@ -402,10 +408,10 @@ void SvgOutputDev::drawString(GfxState * state, GooStr
QString str;
@@ -109,7 +109,11 @@
+ const char * p = s->c_str();
int len = s->getLength();
CharCode code;
- Unicode *u = nullptr;
+- Unicode *u = nullptr;
++ const Unicode *u = nullptr;
+ int uLen;
+ double dx, dy, originX, originY;
+ while (len > 0) {
@@ -429,7 +435,7 @@ void SvgOutputDev::drawString(GfxState * state, GooStr
double x = state->getCurX();
double y = state->getCurY();
@@ -144,6 +148,24 @@
{
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
imgStr->reset();
+@@ -488,7 +494,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *
+ if (maskColors) {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+
+ for (int x = 0; x < width; x++) {
+@@ -507,7 +513,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *
+ } else {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+ }
+
@@ -522,7 +528,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *
return;
}
diff --git a/editors/calligra/files/patch-gentoo-kf5-5.61-headers b/editors/calligra/files/patch-sheets_plugins_calendar_CalendarToolWidget.cpp
index 004cf6df8802..8e75ffc7f720 100644
--- a/editors/calligra/files/patch-gentoo-kf5-5.61-headers
+++ b/editors/calligra/files/patch-sheets_plugins_calendar_CalendarToolWidget.cpp
@@ -3,13 +3,7 @@ From: David Faure <faure@kde.org>
Date: Tue, 23 Jul 2019 13:02:34 +0200
Subject: Fix compilation with Qt 5.13 (missing include)
----
- sheets/plugins/calendar/CalendarToolWidget.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/sheets/plugins/calendar/CalendarToolWidget.cpp b/sheets/plugins/calendar/CalendarToolWidget.cpp
-index b10b230..0c5eeb6 100644
---- sheets/plugins/calendar/CalendarToolWidget.cpp
+--- sheets/plugins/calendar/CalendarToolWidget.cpp.orig 2018-01-26 09:24:44 UTC
+++ sheets/plugins/calendar/CalendarToolWidget.cpp
@@ -30,6 +30,7 @@
#include <kdatepicker.h>
@@ -19,5 +13,3 @@ index b10b230..0c5eeb6 100644
namespace Calligra
{
---
-cgit v1.1
diff --git a/editors/calligra/files/patch-git_70be8c4 b/editors/calligra/files/patch-stage_part_KPrPresentationTool.cpp
index e8f74261cff9..e8f74261cff9 100644
--- a/editors/calligra/files/patch-git_70be8c4
+++ b/editors/calligra/files/patch-stage_part_KPrPresentationTool.cpp
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index 830a279867b2..f6f62b0386ee 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -3,6 +3,7 @@
PORTNAME= kile
DISTVERSIONPREFIX= v
DISTVERSION= 3.0b3
+PORTREVISION= 1
CATEGORIES= editors kde
MAINTAINER= kde@FreeBSD.org
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 4fd545fcaae5..125f469d80d9 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -1,4 +1,5 @@
# $FreeBSD$
+PORTREVISION= 1
.include "${.CURDIR}/Makefile.common"
diff --git a/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.cxx b/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.cxx
new file mode 100644
index 000000000000..99838af2f284
--- /dev/null
+++ b/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.cxx
@@ -0,0 +1,35 @@
+--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.orig 2019-10-27 14:16:14 UTC
++++ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -866,7 +866,7 @@ void PDFOutDev::eoClip(GfxState *state)
+ void PDFOutDev::drawChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
+- CharCode, int /*nBytes*/, Unicode *u, int uLen)
++ CharCode, int /*nBytes*/, const Unicode *u, int uLen)
+ {
+ assert(state);
+
+@@ -982,7 +982,7 @@ void PDFOutDev::drawImageMask(GfxState* pState, Object
+ void PDFOutDev::drawImage(GfxState*, Object*, Stream* str,
+ int width, int height, GfxImageColorMap* colorMap,
+ poppler_bool /*interpolate*/,
+- int* maskColors, poppler_bool /*inlineImg*/ )
++ const int* maskColors, poppler_bool /*inlineImg*/ )
+ {
+ if (m_bSkipImages)
+ return;
+@@ -1004,12 +1004,12 @@ void PDFOutDev::drawImage(GfxState*, Object*, Stream*
+ {
+ GfxRGB aMinRGB;
+ colorMap->getColorSpace()->getRGB(
+- reinterpret_cast<GfxColor*>(maskColors),
++ reinterpret_cast<const GfxColor*>(maskColors),
+ &aMinRGB );
+
+ GfxRGB aMaxRGB;
+ colorMap->getColorSpace()->getRGB(
+- reinterpret_cast<GfxColor*>(maskColors)+gfxColorMaxComps,
++ reinterpret_cast<const GfxColor*>(maskColors)+gfxColorMaxComps,
+ &aMaxRGB );
+
+ aMaskBuf.push_back( colToByte(aMinRGB.r) );
diff --git a/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.hxx b/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.hxx
new file mode 100644
index 000000000000..24811c9d6743
--- /dev/null
+++ b/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.hxx
@@ -0,0 +1,39 @@
+--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx.orig 2019-10-27 14:16:24 UTC
++++ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -232,10 +232,18 @@ namespace pdfi
+ virtual void eoClip(GfxState *state) override;
+
+ //----- text drawing
++#if POPPLER_CHECK_VERSION(0, 82, 0)
+ virtual void drawChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
++ CharCode code, int nBytes, const Unicode *u, int uLen) override;
++#else
++ virtual void drawChar(GfxState *state, double x, double y,
++ double dx, double dy,
++ double originX, double originY,
+ CharCode code, int nBytes, Unicode *u, int uLen) override;
++#endif
++
+ #if POPPLER_CHECK_VERSION(0, 64, 0)
+ virtual void drawString(GfxState *state, const GooString *s) override;
+ #else
+@@ -248,10 +256,17 @@ namespace pdfi
+ int width, int height, poppler_bool invert,
+ poppler_bool interpolate,
+ poppler_bool inlineImg) override;
++#if POPPLER_CHECK_VERSION(0, 82, 0)
+ virtual void drawImage(GfxState *state, Object *ref, Stream *str,
+ int width, int height, GfxImageColorMap *colorMap,
+ poppler_bool interpolate,
++ const int* maskColors, poppler_bool inlineImg) override;
++#else
++ virtual void drawImage(GfxState *state, Object *ref, Stream *str,
++ int width, int height, GfxImageColorMap *colorMap,
++ poppler_bool interpolate,
+ int* maskColors, poppler_bool inlineImg) override;
++#endif
+ virtual void drawMaskedImage(GfxState *state, Object *ref, Stream *str,
+ int width, int height,
+ GfxImageColorMap *colorMap,
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index de068a723941..6e10a00cf51a 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${TIMESTAMP}
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 4
CATEGORIES= editors java
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-${TIMESTAMP}/source/ \
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index f8639a28f776..e03d9ed4c4f6 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= texstudio
DISTVERSION= 2.12.16
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors
MAINTAINER= rigoletto@FreeBSD.org
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 27fc1c1b903b..6a5bef574220 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -4,7 +4,7 @@
PORTNAME= texworks
DISTVERSIONPREFIX= release-
DISTVERSION= 0.6.2
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= editors
MAINTAINER= hrs@FreeBSD.org