aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-03-27 23:45:18 +0800
committerijliao <ijliao@FreeBSD.org>2001-03-27 23:45:18 +0800
commit14534529c15fe720f617c7f72c1a639723a58fd0 (patch)
treef1b68867b8d4267d8b247cec6156e654c148ed25 /editors
parent02a4bd131c8ccc4efd99e721355d377d4719b1bc (diff)
downloadfreebsd-ports-gnome-14534529c15fe720f617c7f72c1a639723a58fd0.tar.gz
freebsd-ports-gnome-14534529c15fe720f617c7f72c1a639723a58fd0.tar.zst
freebsd-ports-gnome-14534529c15fe720f617c7f72c1a639723a58fd0.zip
add poedit
gettext catalogs (.po files) editor
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/poedit/Makefile25
-rw-r--r--editors/poedit/distinfo1
-rw-r--r--editors/poedit/files/patch-install::Makefile.in13
-rw-r--r--editors/poedit/pkg-comment1
-rw-r--r--editors/poedit/pkg-descr22
-rw-r--r--editors/poedit/pkg-plist7
7 files changed, 70 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 168a50b85324..fb976ad09dc9 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -76,6 +76,7 @@
SUBDIR += offix-editor
SUBDIR += openoffice
SUBDIR += pico
+ SUBDIR += poedit
SUBDIR += psgml-emacs
SUBDIR += psgml-emacs20
SUBDIR += psgml-mule
diff --git a/editors/poedit/Makefile b/editors/poedit/Makefile
new file mode 100644
index 000000000000..b7e4c77246f7
--- /dev/null
+++ b/editors/poedit/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: poedit
+# Date created: Mar 27, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= poedit
+PORTVERSION= 1.0.3
+CATEGORIES= editors
+MASTER_SITES= http://www.volny.cz/v.slavik/poedit/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
+ wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/editors/poedit/distinfo b/editors/poedit/distinfo
new file mode 100644
index 000000000000..87f7aa0aeae3
--- /dev/null
+++ b/editors/poedit/distinfo
@@ -0,0 +1 @@
+MD5 (poedit-1.0.3.tar.gz) = 87cea627b2644ada54a328449938eb05
diff --git a/editors/poedit/files/patch-install::Makefile.in b/editors/poedit/files/patch-install::Makefile.in
new file mode 100644
index 000000000000..3e1000109984
--- /dev/null
+++ b/editors/poedit/files/patch-install::Makefile.in
@@ -0,0 +1,13 @@
+--- install/Makefile.in.orig Tue Mar 27 13:41:45 2001
++++ install/Makefile.in Tue Mar 27 13:42:15 2001
+@@ -197,8 +197,8 @@
+ @USE_GNOME_TRUE@install-gnome:
+ @USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/pixmaps
+ @USE_GNOME_TRUE@ install -m 644 $(top_srcdir)/src/bitmaps/appicon.xpm $(GNOME_DATA_DIR)/pixmaps/poedit.xpm
+-@USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/gnome/apps/Development
+-@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.desktop $(GNOME_DATA_DIR)/gnome/apps/Development
++@USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/apps/Development
++@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.desktop $(GNOME_DATA_DIR)/apps/Development
+ @USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/mime-info
+ @USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.mime $(GNOME_DATA_DIR)/mime-info
+ @USE_GNOME_TRUE@ install -m 644 poedit.keys $(GNOME_DATA_DIR)/mime-info
diff --git a/editors/poedit/pkg-comment b/editors/poedit/pkg-comment
new file mode 100644
index 000000000000..b98da6991200
--- /dev/null
+++ b/editors/poedit/pkg-comment
@@ -0,0 +1 @@
+gettext catalogs (.po files) editor
diff --git a/editors/poedit/pkg-descr b/editors/poedit/pkg-descr
new file mode 100644
index 000000000000..61c8b05fbc88
--- /dev/null
+++ b/editors/poedit/pkg-descr
@@ -0,0 +1,22 @@
+poEdit is cross-platform gettext catalogs (.po files) editor. It is built
+with wxWindows toolkit and can run on any platform supported by it (although
+it was tested only on Unix with GTK+ and Windows). It aims to provide more
+convenient approach to editing catalogs than launching vi and editing the
+file by hand.
+
+Here is a brief features list:
+
+ - User friendly way of editing entries. You can easily navigate in large
+ catalogs, easily enter or modify entries (fuzzy flag is automatically
+ removed if you change translation, you can copy original string to
+ translation by pressing Alt-I)
+ - Whitespaces highlighting
+ - Fuzzy and untranslated records highlighting. Furthermore, untranslated
+ and fuzzy translations are displayed at the top of the list
+ - Automatic compilation of .mo files (optional)
+ - Automatic headers update
+ - References browser lets you see where in what context the string is used
+ - You can use poEdit to scan source code for translatable strings
+ - Integration with KDE and GNOME desktops
+
+WWW: http://www.volny.cz/v.slavik/poedit/
diff --git a/editors/poedit/pkg-plist b/editors/poedit/pkg-plist
new file mode 100644
index 000000000000..9f2a66ab2dc7
--- /dev/null
+++ b/editors/poedit/pkg-plist
@@ -0,0 +1,7 @@
+bin/poedit
+share/gnome/apps/Development/poedit.desktop
+share/gnome/mime-info/poedit.keys
+share/gnome/mime-info/poedit.mime
+share/gnome/pixmaps/poedit.xpm
+share/poedit/poedit_help.htb
+@dirrm share/poedit