aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2014-11-07 20:52:21 +0800
committerashish <ashish@FreeBSD.org>2014-11-07 20:52:21 +0800
commit24b9912dd79860a4e610d06c4f22a28563b01114 (patch)
treefa23d8590d994757d8cd09ae8248055906bbb6c6 /editors
parent05c630a7e2df4cc8bbd4546c8a4abb1e4f5b9de2 (diff)
downloadfreebsd-ports-gnome-24b9912dd79860a4e610d06c4f22a28563b01114.tar.gz
freebsd-ports-gnome-24b9912dd79860a4e610d06c4f22a28563b01114.tar.zst
freebsd-ports-gnome-24b9912dd79860a4e610d06c4f22a28563b01114.zip
- Fix pkg-install script to correctly install emacs games scores files[1]
- Fix building port when ALSA option is enabled[2] - Depend on desktop-file-utils when X11 option is enabled[3] - Bump PORTREVISION to account for these changes PR: 194624[1], 194862[2] Submitted by: crest <crest at sahiro.org>[2] Reported by: Joseph Mingrone <jrm at ftfl.ca>[1], Richard Kuhns <rjk at wintek.com>[3] (via private email)
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs-devel/Makefile5
-rw-r--r--editors/emacs-devel/files/pkg-install.in (renamed from editors/emacs-devel/pkg-install)3
2 files changed, 8 insertions, 0 deletions
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index 471d3652ee1c..a0e2304e603d 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}.${EMACS_REV}
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= editors ipv6
MASTER_SITES= http://distfiles.pirateparty.in/%SUBDIR%/ \
@@ -31,6 +32,8 @@ INFO_PATH= ${DATADIR_REL}/info
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env autoheader:env
+SUB_FILES= pkg-install
+SUB_LIST+= ARCHLIBDIR=${PREFIX}/libexec/emacs/${EMACS_VER}/${CONFIGURE_TARGET}
SHEBANG_FILES= ${WRKSRC}/lib-src/grep-changelog
# Append --without-compress-install to prevent emacs from compressing info
@@ -79,6 +82,7 @@ OPTIONS_SUB= SOURCES
SOUND_CONFIGURE_OFF= --with-sound=no
ALSA_CONFIGURE_ON= --with-sound=alsa
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
OSS_CONFIGURE_ON= --with-sound=oss
DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
@@ -95,6 +99,7 @@ SVG_CONFIGURE_WITH= rsvg
X11_CONFIGURE_WITH= x
X11_USE= XORG=x11
+X11_USES= desktop-file-utils
X11_PLIST_DIRSTRY_OFF= share/icons/hicolor/scalable/mimetypes \
share/icons/hicolor/scalable/apps \
share/icons/hicolor/scalable \
diff --git a/editors/emacs-devel/pkg-install b/editors/emacs-devel/files/pkg-install.in
index 70280bfdbbd7..7c3bd729433c 100644
--- a/editors/emacs-devel/pkg-install
+++ b/editors/emacs-devel/files/pkg-install.in
@@ -3,12 +3,15 @@
# $FreeBSD$
GAMESROOT=/var/games/emacs
+ARCHLIBDIR=%%ARCHLIBDIR%%
if [ "$2" = "POST-INSTALL" ]; then
umask 022
mkdir -p $GAMESROOT
touch $GAMESROOT/snake-scores
touch $GAMESROOT/tetris-scores
+ chown games $ARCHLIBDIR/update-game-score
+ chmod u+s $ARCHLIBDIR/update-game-score
chown games $GAMESROOT
chmod 775 $GAMESROOT
fi